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Microsoft Excel is a spreadsheet program that allows the user to organize, format, and calculate data using rows and 

columns. It provides the tools to prepare various types of reports, such as Exam Reports, Fee Reports, Employee Salary 

Sheets, and Business Accounts. 

The most important feature of MS-Excel is Automatic Recalculation: if you modify the input data, the formulated 

result (calculation) updates automatically without any manual effort. 

File Terminology & Extension 

➢ Workbook: An MS-Excel file is technically called a "Workbook". 

➢ Worksheet: The pages inside the workbook where you work are called "Spreadsheets" or "Worksheets". 

➢ Extension: The default file extension for Excel (Version 2010 to latest) is .xlsx. 

➢ Spreadsheet: A Spreadsheet is an electronic grid consisting of rows and columns used to organize data and 

perform automatic calculations. 

Difference between manual spreadsheet and electronic spreadsheet. 

A manual spreadsheet is a paper-based ledger requiring hand-written calculations, whereas an electronic spreadsheet is 

a digital file that performs calculations automatically." 

Features of MS-Excel 

➢ Data Analysis: It provides powerful tools to analyze large amounts of data efficiently. 

➢ Formulas & Functions: It includes a vast library of Mathematical, Financial, Logical, and Text formulas to 

perform complex calculations. 

➢ Visualization: It has the facility to organize and present data in graphical forms (Charts and Graphs). 

➢ Data Management: It offers easy options for Sorting (arranging data) and Filtering (viewing specific data). 

➢ Usage: It is widely used for Payroll, Accounting, Data Entry, and various business management purposes. 

 

How to Start MS-Excel 

 

Method 1: (Works on All Versions of Windows O.S. 

➢ Press Windows Button + R on your keyboard to open the Run box. 

➢ Type excels inside the box. 

➢ Press Enter or click Ok. 

 

Method 2: Using the Start Menu 

➢ For Windows 7 

Start → All Programs → Microsoft Office → Microsoft Excel. 

➢ For Windows 10 / 11: 

Press the Windows Key, type "Excel", and click the icon. 
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Parts of the MS-Excel Interface 

Here are the key components of the Microsoft Excel window: 

❖ Quick Access Toolbar (QAT): Located at the very top-left corner. It contains frequently used commands 

like Save, Undo, and Redo. 

❖ The Ribbon: This is the panel at the top containing tabs like Home, Insert, Page Layout, Formulas, etc. It 

holds all the tools and buttons used to work in Excel. 

❖ Name Box: Located to the left of the Formula Bar and below of ribbon, It displays the address of the currently 

selected cell (e.g., A1, B5). 

❖ Formula Bar: It Located next right to the Name Box. It displays and allows you to edit the content or 

formula of the selected cell. 

❖ Column Header: The vertical divisions labelled with alphabets (A, B, C...). Total Columns in one 

sheet: 16,384. Range: Starts from "A" and ends at "XFD". 

 

Navigation Shortcuts: 

➢ Go to Last Column: Ctrl + Right Arrow 

➢ Go to First Column: Ctrl + Left Arrow 

❖ Row Header: The horizontal divisions labeled with numbers (1, 2, 3...). 

Total Rows in one sheet: 1,048,576. 

Navigation Shortcuts: 

➢ Go to Last Row: Ctrl + Down Arrow 



 

 MS - EXCEL 
 

3                                                                                                                                                                                        WWW.ICAEDU.CO.IN 
 

➢ Go to First Row: Ctrl + Up Arrow 

❖ Cell: A Cell is the intersection point of a Row and a Column. This is where you type data. 

➢ Total Cells per Sheet: Approx 17 billion (17,179,869,184). 

➢ You can type up to 32,767 characters in a single cell. 

➢ Visual Limit: However, only the first 1,024 characters will be visible inside the cell. To see the rest, you 

have to look at the Formula Bar. 

When you type a number that is 12 digits or longer (e.g., 123456789012), Excel automatically converts it 

into Scientific Notation. 

What happens: The number looks like 1.23E+11 instead of the full number. 

How to Fix: 

➢ Select the cell. 

➢ Press Ctrl + 1 (Format Cells). 

➢ Select "Number" and set Decimal places to 0. 

➢ Click OK. The full number will now be visible. 

 

❖ Worksheet (Sheet Tab): It is the working area (the grid) where you enter data. 

• Default Sheets: 

➢ Excel 2010/2013: 3 Sheets 

➢ Excel 2016/2019/365: 1 Sheet 

(Note: You can add as many sheets as your computer's RAM allows.) 

• Insert New Sheet Shortcut: Shift + F11 

❖ Zoom Slider: Located at the bottom-right corner. It allows you to Zoom In (+) or Zoom Out (-) of the 

worksheet view (Range: 10% to 400%). 

The Excel Window Structure 

When you open Excel, you are interacting with two layers: 

➢ Application Window: An outer window through which user communication with MS-Excel is called 

application window. 

➢ Workbook / spreadsheet Window: In inner windows in which user enter the da ta in rows and columns is 

called workbook window. 

Data in Excel 

You can enter different types of information into an Excel cell. Excel automatically detects the type of data you 

type: 

Labels (Text): Any combination of letters (A-Z) and numbers that are not used for math. 

➢ Example: "Employee Name", "EMP-102", "Total". 

➢ Behaviour: By default, Text aligns to the Left. 

Values (Numbers): Digits (0-9) used for calculation. 

➢ Example: 500, 99.5, -20. 

➢ Behaviour: By default, Numbers align to the Right. 

Date & Time: Dates and Times are valid data types. 
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➢ Example: 15-Aug-2023, 10:30 AM. 

➢ Symbols: Special characters like @, #, $, %. 

Formulas: Instructions for calculations. 

➢ Must Start with: An equals sign (=). 

➢ Example: =SUM(A1:A5) or =A1+B1. 

How to Edit Cell Contents 

If you make a mistake or need to update data, use one of these three methods: 

➢ Double-Click: Double-click the cell with your mouse to edit directly inside it. 

➢ Shortcut Key: Select the cell and press the F2 key. 

➢ Formula Bar: Select the cell, click inside the Formula Bar (top), and type your changes. 

➢ Cancel Edit: If you are editing a cell and realize you don't want to change it, just press the Esc (Escape) key 

on your keyboard to cancel. 

Difference between Formula & Function 

Formula: A customized calculation created by the User manually (e.g., =A1+B1). 

Function: A pre-defined calculation built into Excel automatically (e.g., =SUM (A1:B1)). 

 

WORKING WITH EXCEL 

 

File Tab: It displays, new, open, save, save as, info, close, option. 

Option / Excel Option: Excel Options" is the Settings Menu or Control Panel of Excel. It allows you to change how 

Excel works, calculates, saves, and looks.  

How to Open it: 

Process: Click File → Options. 

There are many excel options: 

➢ General, Proofing, Language→ These work exactly the same way as in MS Word. 

➢ Formulas: This section controls how Excel performs math and calculations. 

Example 1: Fix "Stuck" Formulas (Calculation Options) 

You changed numbers in your sheet, but the Total (Sum) is not changing. It feels like Excel is "stuck". 

Reason: Calculation is set to "Manual". 

Process: 

Go to File → Options → Formulas. →Under "Calculation options", select Automatic. →Click OK. 

Example 2: Columns changed from A, B, C to 1, 2, 3 (R1C1 Style) 

Process: Go to File →Options →Formulas → Under Working with formulas, Check / Uncheck the box "R1C1 

reference style" → Click OK. 

Example 3: Annoying Green Triangles (Background Error Checking) 

Process: Go to File →Options →Formulas → Under Error Checking, Uncheck the box "Enable background 

error checking" → Click OK. 

Example 4: Disable Formula Suggestions (Formula AutoComplete) 



 

 MS - EXCEL 
 

5                                                                                                                                                                                        WWW.ICAEDU.CO.IN 
 

Process: Go to File →Options →Formulas → Under Working with formulas, uncheck "Formula 

AutoComplete" → Click OK. 

Example 5: Allow Circular References (Iterative Calculation) 

out is doing a complex financial model where Cell A depends on Cell B, and Cell B depends on Cell A. Normally 

Excel gives an error. You want to allow this. 

Process: Go to File →Options →Formulas →  Under Calculation options, Check the box "Enable iterative 

calculation" → Click OK. 

➢ Save: This controls how your files are saved and recovered in case of a crash. 

Process: Click on File →Click on options →Click on Save → Change "Save Auto Recover information 

every" to 1 minute. → In "Save files in this format", select your preferred type (e.g., Excel 

Workbook or Macro-Enabled Workbook). →Click OK. 

➢ Advanced: The Advanced tab controls the Behaviour and Environment of Excel. 

Change Enter Direction 

Process: Go to File → Options → Advanced. →Under Editing options, find "After pressing Enter, move 

selection". →Change Direction from Down to Right. →Click OK. 

Custom Lists 

Process: Go to File → Options → Advanced. →Scroll to the very bottom to the General section. 

Click Edit Custom Lists.... →Type your list (e.g., Patna, Gaya, Chapra) in the box and click Add. 

→Click OK. 
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MATHEMATICAL & STATICAL FUCTION 
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2 1 RAJ 90 78 65 ? ? ? ? ? ? ? ? ? 

3 2 RAJU 78 90 87 ? ? ? ? ? ? ? ? ? 

 

SUM: [Mathematical]: This function is used to add all the numbers in a specific range of cells. We use it to calculate 

the "Total Marks". 

Syntax: =SUM(Range) 

Example: =SUM (C2:E2) 

 

 PERCENTAGE (Manual Formula): There is no direct function for percentage in Excel. We use a mathematical 

formula to calculate it based on Total Marks (Assuming full marks are 300). 

Syntax: = (Obtained Marks * 100) / Total Marks 

Example: =(F2*100)/300 

 

 AVERAGE: [Statistical]: This function calculates the arithmetic mean (average) of the selected numbers. 

Syntax: =AVERAGE(Range) 

Example: =AVERAGE (C2:E2) 

 

MAX (Maximum): [Statistical]: This function returns the largest (highest) value from the selected range. It helps to 

find the highest score in a subject. 

Syntax: =MAX(Range) 

Example: =MAX (C2:E2) 

 

MIN (Minimum): [Statistical]: This function returns the smallest (lowest) value from the selected range. It helps to 

find the lowest score in a subject. 

Syntax: =MIN(Range) 

Example: =MIN (C2:E2) 

 

COUNT: [Statistical]: This function counts the number of cells that contain numbers only. It ignores text.  

Syntax: =COUNT(Range) 

Example: =COUNT (C2:E2) 
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COUNTA: [Statistical]: This function counts the number of cells that are not empty. It counts both Text and 

Numbers. 

Syntax: =COUNTA(Range) 

Example: =COUNTA (B2:E2) 

 

COUNTBLANK: [Statistical]: This function counts the empty (blank) cells in a specific range. It helps to find if a 

student was absent (missing marks). 

Syntax: =COUNTBLANK(Range) 

Example: =COUNTBLANK (C2:E2) 

 

 RANK: [Statistical]: This function returns the rank (position) of a number in a list of numbers. It helps to determine 

1st, 2nd, or 3rd position in class. 

Syntax: =RANK (Number, Ref_Range) 

Example: =RANK (F2, $F$2: $F$4) 

 Compares Raj's total [F2] with all students' totals [$F$2: $F$4] to give a rank). 

 

SQRT (Square Root): [Mathematical]: This function returns the square root of a number. (Kisi sankhya ka varg-

mool nikalna). 

Syntax: =SQRT(Select_Number) 

Example: =SQRT (64) 

Result: = 8 

 

POWER: [Mathematical]: This function calculates the power of a number. 

Syntax: =POWER (Base_Number, Power_Value) 

Example: =POWER (5, 3) 

Result: = 125 

 

LCM: [Mathematical]: This function returns the least common multiple of integers. (Laghutam Samapvartak 

nikalna). 

Syntax: =LCM (Number1, Number2) 

Example: =LCM (12, 18) 

 

MOD: [Mathematical]: This function returns the Remainder (Shesh-phal) after dividing a number. It is used to find 

what is left over. 

Syntax: =MOD (Number, Divisor) 

Example: =MOD (10, 3) 

Result: = 1 
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INT (Integer): [Mathematical]: This function removes the decimal part and returns only the integer (whole number) 

part. Note: It does not round off; it just cuts the decimals. 

Syntax: =INT (Decimal Number) 

Example: =INT (99.95) 

Result: = 99 

 

ABS (Absolute Value): [Mathematical]: This function converts negative numbers into positive numbers. (Minus 

sign hatane ke liye). 

Syntax: =ABS(Number) 

Example: =ABS (-500) 

Result: = 500 

 

 ROMAN: [Mathematical]: This function converts a standard number (Arabic) into Roman numerals (I, II, V, X). 

Students love this function! 

Syntax: =ROMAN(Number) 

Example: =ROMAN (2024) 

Result: MMXXIV 

 

CONVERT: [Engineering]: This is a magical function used to convert one measurement unit to another (e.g., Meters 

to Kilometres, Days to Hours). 

Syntax: =CONVERT (Number, "From Unit", "To Unit") 

Important: You must use double quotes "" for units. 

Example 1 (Distance): =CONVERT (1000, "m", "km" 

Result: 1, converts 1000 Meters to 1 KM 
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TEXT FUNCTION 

UPPER: Converts all letters in a text string to UPPERCASE (Capital letters). 

Syntax: =UPPER (Select Text) 

Example: =UPPER("computer") 

Result: COMPUTER 

 

LOWER: Converts all letters in a text string to lowercase (Small letters). 

Syntax: =LOWER (Select Text) 

Example: =LOWER("INDIA") 

Result: india 

 

PROPER: Capitalizes the First Letter of each word and converts the rest to lowercase. 

Syntax: =PROPER(Select_Text) 

Example: =PROPER ("mr raj kumar") 

Result: Mr Raj Kumar 

 

LEFT: Returns a specific number of characters from the start (left side) of a text string. 

Syntax: =LEFT (Select_Text, Number_of_Chars) 

Example: =LEFT ("Superman", 5) 

Result: Super 

 

RIGHT: Returns a specific number of characters from the end (right side) of a text string. 

Syntax: =RIGHT (Select_Text, Number_of_Chars) 

Example: =RIGHT ("Superman", 3) 

Result: man 

 

 MID: Returns characters from the middle of a text string, given a starting position and length. 

Syntax: =MID (Select_Text, Start_Number, Number_of_Chars) 

Example: =MID ("Computer", 4, 3) 

Result: put 

 

LEN (Length): Returns the number of characters in a text string (counts letters, numbers, and spaces). 

Syntax: =LEN(Select_Text) 

Example: =LEN ("Hello India") 

Result: 11 

 

REPT (Repeat): Repeats a text a specified number of times. 

Syntax: =REPT ("Text", Number_of_Times) 

Example: =REPT ("Joy ", 3) 
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Result: Joy Joy Joy 

 

 CONCATENATE: Joins two or more text strings into one string. 

Syntax: =CONCATENATE (Text1, Text2, Text3...) 

Example: =CONCATENATE ("Raj", " ", "Kumar") 

(Note: We added " " separately to create a space between names). 

Result: Raj Kumar 

 

SUBSTITUTE: Replaces specific text with new text. Used to fix mistakes or change formats (e.g., changing "-" to 

"/"). 

Syntax: =SUBSTITUTE (Select_Cell, "Old_Text", "New_Text") 

Example: =SUBSTITUTE ("DL-01-2023", "-", "/") 

Result: DL/01/2023 

 

FIND: Finds the starting position (number) of a specific character. Used to locate symbols like "@" or "-". 

Syntax: =FIND ("Text_to_Find", Select_Cell) 

Example: =FIND ("@", "raj@gmail.com") 

Result: 4 (Because @ is the 4th character). 

 

TEXT: Converts a value (like a Date) to text in a specific format. 

Syntax: =TEXT (Value, "Format_Code") 

Example: =TEXT ("26-01-2026", "DDDD") 

Result: MONDAY 

Example: =TEXT ("26-01-2026", "MMM") 

Result: Jan 

 

REPLACE: Replaces part of a text string with a different text string, based on the Position. It is often used to hide 

sensitive data like passwords or account numbers. 

Syntax: =REPLACE (Old_Text, Start_Num, Num_Chars, "New_Text") 

Example: =REPLACE ("1234567890", 1, 6, "XXXXXX") 

Result: XXXXXX7890 

 

SEARCH (Case-Insensitive Find): Finds the starting position of a specific text string inside another text string. 

Unlike FIND, this is not case-sensitive (it treats 'A' and 'a' as the same). 

Syntax: =SEARCH ("Text_to_Find", Select_Cell) 

Example: =SEARCH ("r", "Ram") 

Note: FIND gives an error here, but SEARCH works 

Result: 1 
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EXACT: Checks if two text strings are exactly the same (including Capital/Small letters). It returns TRUE or FALSE. 

Syntax: =EXACT (Text1, Text2) 

Example: =EXACT ("India", "india") 

Result: FALSE 

 

FIXED: Rounds a number to a specified number of decimals, formats it with commas (thousands separator), and 

converts the result to Text. 

Syntax: =FIXED (Number, Decimals) 

Example: =FIXED (12345.6789, 2) 

Result: 12,345.68 (Notice the comma and rounding). 
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DATE & TIME FUNCTION 

Start Date: January 1, 1900. (Excel cannot calculate dates before year 1900). 

End Date: December 31, 9999. 

(Note: If you type a date like 15-Aug-1857, Excel will treat it as "Text" and formulas will not work). 

Excel does not see dates as "Text" (like Jan, Feb). It sees dates as Serial Numbers. 

Excel starts counting dates from January 1, 1900. 

01-Jan-1900 = Serial Number 1 

Today: Every day, the number increases by 1. 

25-Oct-2023 = Serial Number 45224 

Every day, the number increases by 1 

 

Shortcut to insert date & Time 

➢ Insert Current Date Ctrl + ; (Semicolon)  

➢ Insert Current Time Ctrl + Shift + ;  

➢ Change Date Format Ctrl + Shift + #  

➢  

NOW (): Returns the current date and time. It updates automatically whenever the sheet recalculates. 

Syntax: =NOW () 

Example: =NOW () 

Result: 25/02/2026 14:30 

 

TODAY (): Returns only the current date (without time). Useful for daily reports and age calculations. 

Syntax: =TODAY () 

Example: =TODAY () 

Result: 25/10/2023 

 

DAY (): Returns the day number (1-31). 

Syntax: =DAY (Serial Number) 

Example: =DAY (“15-02-2026”) 

Result: 15 

 

MONTH: Returns the month number (1-12). 

Syntax: =MONTH (Serial Number) 

Example: =MONTH (“15-02-2026”) 

 Result: 02 

 

YEAR: Returns the year (e.g., 2023). 

Syntax: =YEAR (Serial Number) 

Example: =YEAR (“15-02-2026”) 
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 Result: 2026 

 

DATE (): Creates a valid date from separate Year, Month, and Day numbers. 

Syntax: =DATE (Year, Month, Day) 

Example: =DATE (2023, 12, 25) 

Result: 25-12-2023 

 

TIME (): It Creates a valid time format from separate Hour, Minute, and Second numbers. Useful when data comes in 

separate pieces. 

Syntax: =TIME (Hour, Minute, Second) 

Example: =TIME (14, 30, 0) 

Result: 2:30 PM (Converts 24-hour format to time) 

. 

WEEKDAY (): It Returns a number representing the day of the week (By default: 1 = Sunday, 7 = Saturday). 

Syntax: =WEEKDAY (Select Date) 

Example: =WEEKDAY("15-Aug-1947") 

Result: 6 (Friday). 

 

DAYS360 (): It Calculates the difference between two dates assuming a 360-day year (12 months of 30 days each). 

Syntax: =DAYS360(Start Date, End Date) 

Example: =DAYS360("01/01/2023", "31/12/2023") 

Result: 360 

 

DATEDIF (): It Calculates the exact difference between two dates in Years, Months, or Days. This is a Hidden 

Function (not listed in Excel suggestions). 

Syntax: =DATEDIF (Start Date, End Date, "Unit") 

Units: "Y" (Years), "M" (Months), "D" (Days), "YM" (Months after Years). 

Example (Age): =DATEDIF ("01/01/1990", TODAY (), "Y") 

Result: 33 (Returns current age in years). 

 

NETWORKDAYS (): It Calculates the number of working days between two dates, automatically excluding 

Weekends (Saturday & Sunday). Best for HR Payroll. 

Syntax: =NETWORKDAYS (Start Date, End Date) 

Example: =NETWORKDAYS ("01-Jan-2023", "10-Jan-2023") 

Result: 7 (Total 10 days - 2 Weekend days = 7 Working days + 1 Start day logic) 

. 

EOMONTH (): It Returns the date of the Last Day of a specific month. Useful for billing due dates. 

Syntax: =EOMONTH (Start Date, Months_to_Add) 

Example: =EOMONTH ("15-Feb-2023", 0) 
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Result: 28-Feb-2023 (Automatically finds the last day of Feb). 

 

TEXT (): It Converts a date into a specific text format, like showing the Day Name (Sunday/Monday). 

Syntax: =TEXT (Date Cell, "Format") 

Example: =TEXT (TODAY (), "DDDD") 

Result: Wednesday (Shows the name of today's day). 

 

WEEKNUM (): It Returns the week number of the year (from 1 to 52). Used for weekly progress reports. 

Syntax: =WEEKNUM (Date Cell) 

Example: =WEEKNUM("25-Oct-2023") 

Result: 43 (Means this date falls in the 43rd week of the year). 

 

WORKDAY (): It Calculates a future date by adding a specific number of working days to a start date. It 

automatically skips weekends. 

Syntax: =WORKDAY (Start Date, Days_to_Add) 

Example: =WORKDAY ("01-Jan-2023", 5) 

Result: 06-Jan-2023 (Skips Sat/Sun if they fall in between). 

 

EDATE (): It Returns a date that is a specific number of Months before or after a start date. 

Use Case: Calculating Warranty Expiry or EMI Dates. 

Syntax: =EDATE (Start Date, Months) 

Example: =EDATE ("15-Jan-2023", 3) 

Result: 15-Apr-2023 (Exactly 3 months later). 

 

YEARFRAC (): It Calculates the fraction of a year between two dates. 

Use Case: Calculating exact Employee Service Tenure (e.g., 2.5 Years). 

Syntax: =YEARFRAC (Start Date, End Date) 

Example: =YEARFRAC ("01-Jan-2022", "01-Jul-2023") 

Result: 1.5 (Means 1 and a half years). 
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Logical Functions 

Logical functions are the "Decision Making" function in Excel. 

As we know, we can enter text, numbers, or formulas in a cell. A Logical Formula is a special type of formula where 

the user defines a Condition, and the computer analyses the data to verify if that condition is TRUE or FALSE. 

There are following: 

IF (): The IF function is the most commonly used logical function in Excel. 

It performs a logical test and returns one value if the condition is True, and a different value if the condition is False. 

Syntax: =IF (Logical Test, Value_if_True, Value_if_False) 

➢ Logical Test: The condition you want to check (e.g., Marks >= 33). 

➢ Value_if_True: What to show if the condition is met (e.g., "Pass"). 

➢ Value_if_False: What to show if the condition is NOT met (e.g., "Fail"). 

Data Table: 

Please create this table in Excel to practice the formulas. 
 

A B C D E F G H I J 

1 ROLL NAME PHY CHE MATH TOTAL PER PASS/FAIL DIV 1 DIV 2 

2 1 RAJ 90 78 65 233 77.6 ? ? ? 

3 2 RAJU 30 40 35 105 35.0 ? ? ? 

4 3 MOHAN 20 25 30 75 25.0 ? ? ? 

 

Q.1. Calculate Pass or Fail 

Logic: If the Total Marks (F2) are greater than or equal to 180, then the result is "Pass", otherwise "Fail". 

Syntax: =IF (Condition, "True Result", "False Result") 

Example Formula (Apply in H2): =IF(F2>=200, "Pass", "Fail") 

Q.2. Calculate Division (Based on Percentage) 

Logic: Check percentage (G2) and assign division: 

• >= 60%: First 

• >= 45%: Second 

• >= 30%: Third 

• Otherwise: Fail 

Formula (Apply in I2): =IF(G2>=60, "First", IF(G2>=45, "Second", IF(G2>=30, "Third", "Fail"))) 

 

Q.3.Calculate Division (Subject Wise)  

Logic: A student gets a division only if they pass in ALL subjects (Phy, Che, Math >= 30) AND meet the percentage 

criteria. We use the AND function inside IF to check multiple conditions together. 

Formula (Apply in J2): =IF(AND(C2>=30, D2>=30, E2>=30, G2>=60), "First", IF(AND(C2>=30, D2>=30, 

E2>=30, G2>=45), "Second", IF(AND(C2>=30, D2>=30, E2>=30, G2>=30), "Third", "Fail"))) 

Logical Function Project: Employee Sales Incentive 

Scenario: You are an HR Manager. You need to calculate the Performance Status, Bonus Eligibility, and Final 

Incentive for the sales team based on their targets. 
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The Advanced Data Table: 

(Create this in Excel) 
 

A B C D E F G H 

1 ID NAME REGION ATTENDANCE SALES ($) TARGET 

($) 

STATUS INCENTIVE 

2 101 Amit North 28 65000 50000 ? ? 

3 102 Priya South 20 45000 50000 ? ? 

4 103 Raj North 25 120000 80000 ? ? 

Q.1. Determine Performance Status (Simple IF) 

Logic: If Sales are greater than or equal to Target, status is "Achieved", otherwise "Missed". 

Syntax: =IF (Logical_Test, Value_True, Value_False) 

Formula (Cell G2): =IF(E2>=F2, "Achieved", "Missed") 

Q.2. Calculate Incentive (Nested IF - Multiple Slabs) 

Logic: Companies pay commission based on slabs: 

• Sales > 100,000 : 10% Commission 

• Sales > 50,000 : 5% Commission 

• Below 50,000 : 0 Commission 

Formula (Cell H2): =IF(E2>100000, E2*10%, IF(E2>50000, E2*5%, 0)) 

Q.3. Eligibility for "Super Bonus" (IF + AND) 

Logic: An employee gets a "Super Bonus" ONLY IF: 

Target is Achieved (Sales >= Target) AND 

Attendance is greater than 25 days (Attendance > 25). 

(Both conditions must be true). 

Formula: =IF(AND(E2>=F2, D2>25), "Eligible", "Not Eligible") 

Q.4. Warning Letter (IF + OR) 

Logic: Issue a "Warning" if: 

Sales are below 20,000 OR 

Attendance is below 15 days. 

(If any one condition is bad, give warning). 

Formula: =IF (OR (E2<20000, D2<15), "Issue Warning", "Safe") 

If OR Function: The IF and OR combination is used when you want to check multiple conditions, but you only need 

ANY ONE condition to be True. 

Logic: 

Condition A is True? → Result: True 

Condition B is True? → Result: True 

Both are False? → Result: False 

Please create below table in Excel to practice the formulas. 
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A B C D E 

1 ORDER ID PRODUCT QUANTITY REGION PAYMENT 

2 ORD-101 Laptop 2 North Credit 

3 ORD-102 Mouse 50 South Cash 

4 ORD-103 Printer 10 East Credit 

5 ORD-104 Laptop 5 West Cash 

Example 1: The logistics manager wants to assign "Fast Track" shipping if the order comes from 

the "North" region OR the "East" region. All other regions get "Standard" shipping. 

Logic: Check if Region (Cell D2) is "North" OR Region is "East". 

Formula (Apply in Cell F2): =IF (OR (D2="North", D2="East"), "Fast Track", "Standard") 

Result Analysis: 

ORD-101 (North): One condition is True → Fast Track 

ORD-102 (South): Both conditions are False→ Standard 

ORD-103 (East): One condition is True →Fast Track 

Example 2: The company policy states that a customer gets a discount if they order a Laptop OR if they make 

a Cash payment. 

(If either of these criteria is met, they are eligible). 

Logic: Check if Product (Cell B2) is "Laptop" OR Payment (Cell E2) is "Cash". 

Formula (Apply in Cell G2): =IF (OR (B2="Laptop", E2="Cash"), "Eligible", "Not Eligible") 

 

Result Analysis: 

ORD-101: Product is Laptop. Condition Met. → Eligible 

ORD-102: Product is Mouse (False), but Payment is Cash (True). → Eligible 

ORD-103: Product is Printer (False), Payment is Credit (False). → Not Eligible 

IF AND Function: This function checks multiple things at once. It gives a TRUE result only if ALL conditions are 

correct. 

Example 1: The Manager wants to verify high-risk orders. An order is marked as "Verified" only if the product is 

a "Laptop" AND the payment mode is "Cash". 

(Both conditions must be True). 

Formula: =IF (AND (B2="Laptop", E2="Cash"), "Verified", "Check") 

Result Analysis: 

ORD-101: Product is Laptop (True), but Payment is Credit (False). Result → "Check" 

ORD-104: Product is Laptop (True), and Payment is Cash (True). Result → "Verified" 

Example 2: The Marketing team runs a promotion. A customer gets a "Free Gift" if they are from 

the "North" region and if they buy a "Laptop". 

Formula: =IF (and (D2="North", B2="Laptop"), "Free Gift", "No Gift") 
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A B C D E 

1 DATE SALESMAN BRAND AMOUNT ($) LOCATION 

2 01-Oct Amit Apple 80000 Patna 

3 02-Oct Ravi Samsung 20000 Gaya 

4 02-Oct Amit Apple 60000 Patna 

5 03-Oct Pooja Samsung 25000 Muzaffarpur 

6 03-Oct Ravi Xiaomi 15000 Gaya 

7 04-Oct Amit Samsung 22000 Patna 

Create above table in Excel for practice sumif & countif 

Sumif Function: The SUMIF function is used to add up numerical values based on a Single Condition. 

Instead of adding all numbers, it only adds the numbers that match specific criteria defined by the user. 

Syntax =SUMIF(Range, Criteria, Sum_Range) 

 

Question: Calculate the Total Sales Amount for "Samsung". 

Formula: =SUMIF(C2:C7, "Samsung", D2:D7) 

Result: 67,000 

 

Question: Calculate the Total Money collected by "Pooja". 

Formula: =SUMIF(B2:B7, "Pooja", D2:D7)            

 

Countif Function: The COUNTIF function is used to count the number of cells that meet a single specific condition. 

Instead of counting all cells, it only counts the cells that match the criteria defined by the user. 

Syntax: =COUNTIF(Range, Criteria) 

 

Question: Count how many times "Amit" made a sale. 

Formula: =COUNTIF(B2:B7, "Amit") 

Result: 3 

 

Question: Count how many "Apple" phones were sold. 

Formula: =COUNTIF(C2:C7, "Apple") 

Result: 2 

 

Countifs Function: The COUNTIFS function is used to count the number of cells that meet multiple conditions (two 

or more) at the same time. 

Syntax=COUNTIFS(Criteria_Range1, Criteria1, Criteria_Range2, Criteria2, ...) 

Question: Count how many times "Amit" made a sale in "Patna". 

Formula: =COUNTIFS(B2:B7, "Amit", E2:E7, "Patna") 

Result Analysis: 3 
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Sumifs Function: The SUMIFS function is used to add up numerical values based on multiple conditions (two or 

more). 

Syntax: =SUMIFS(Sum_Range, Criteria_Range1, Criteria1, Criteria_Range2, Criteria2, ...) 

 

Question: Calculate the Total Sales Amount collected by "Ravi" from "Gaya" city. 

Formula: =SUMIFS(D2:D7, B2:B7, "Ravi", E2:E7, "Gaya") 

Result Analysis: 35000 
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Financial Functions 

FV (Future Value) Function: The FV (Future Value) function calculates the future value of an investment based on a 

constant interest rate and periodic payments. 

It is widely used to calculate maturity amounts for Recurring Deposits (RD), SIPs (Mutual Funds), and Insurance 

Plans. 

Syntax: =FV(interst rate/conditon,term,installment) 

Example: 

Question:  Deposit 1,000 per month for 5 years at 11% interest. 

Formula: =FV(11%/12, 60, -1000) 

Question:  Deposit 5,000 every quarter for 5 years at 10% interest. 

Formula: =FV(10%/4, 20, -5000) 

Question:  Deposit 10,000 every 6 months for 5 years at 10% interest. 

Formula: =FV(10%/2, 10, -10000) 

Question:  Deposit 20,000 once every year for 5 years at 8% interest. 

Formula: =FV(8%, 5, -20000) 

Question:  Deposit 10 every day for 5 years at 5% interest. 

Formula: =FV(5%/365, 1825, -10) 

Reason for Minus (-) Sign: 

In Excel Financial Functions, the logic follows the "Cash Flow" rule: 

We use a Minus (-) sign for the deposit amount because it represents money leaving your pocket (investment), so the 

final result will be Positive (money coming back to you). 

 

PMT (Payment / Per Month Term): PMT (Payment) function is used to calculate the Equated Monthly 

Installment (EMI) for a loan.It helps you find out exactly how much money you need to pay to the bank every month 

if you take a  Loan. 

Syntax: =PMT(Interest/Condition, Term, -Loan Amount) 

Example: 

Question: Loan of 1,00,000 for 5 years at 12% interest. 

Formula: =PMT(12%/12, 60, -100000) 

Question: Loan of 1,00,000 for 5 years at 12% interest. 

Formula: =PMT(12%/4, 20, -100000) 

Question: Loan of 1,00,000 for 5 years at 12% interest. 

Formula: =PMT(12%/2, 10, -100000) 

Question: Loan of 1,00,000 for 5 years at 12% interest. 

Formula: =PMT(12%, 5, -100000) 

Question: Loan of 1,00,000 for 1 year (365 days) at 12% interest. 

Formula: =PMT(12%/365, 365, -100000) 

 

PV(Present Value): It is used to calculate the Loan Amount based on your EMI capacity. 
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Syntax =PV(Rate, Nper, Pmt) 

Question: You want to buy a Car. You can afford an EMI of ₹5,000 per month. The Bank offers a loan for 5 

Years (60 Months) at 11% interest. 

Formula: =PV(11%/12, 60, -5000) 

 

IPMT (Interest Payment):- The IPMT function calculates the Interest amount inside a specific EMI payment. 

Syntax: =IPMT(Interest/Condition, Inst. No., Total Inst.,- Loan Amount) 

Example =IPMT(11%/12, 1, 60, 100000) 

 

PPMT (Principal Payment/Per Month Term): The PPMT function calculates the Principal amount inside a specific 

EMI payment.  

Syntax:  =PPMT(Interest/Condition, Inst. No.., Total Inst., Loan Amount) 

Example  =PPMT(11%/12, 1, 60, 100000) 

 

NPER Function: The NPER function calculates the Total Number of Periods (Months/Years) required to pay off a 

loan. 

Situation: 

Imagine you took a loan of ₹ 1,00,000. The bank charges 12% interest. You can afford to pay only ₹ 2,500 per 

month. You want to know how many months you need to keep paying. 

Syntax:=NPER(Rate, Pmt, Pv) 

Example =NPER(12%/12, -2500, 100000) 

Result: 51.1 Months 

RATE Function: The RATE function calculates the actual Interest Rate charged on a loan. 

Situation: 

A shopkeeper sells you a Bike for ₹ 50,000. He says: "Just pay ₹ 1,500 for 48 Months (4 Years)." You want to 

know the hidden Interest Rate he is charging. 

Syntax: =RATE(Nper, Pmt, Pv) * 12 

(Note: The function gives a monthly rate, so we multiply by 12 to get the Annual Rate). 

Example =RATE(48, -1500, 50000) * 12 

Result: 19.14% 
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PROJECT-1 

Create this in Excel for practice,  Columns A to G are Data. Column H is the Question 
 

A B C D E F G H 

1 ID CLIENT PRODUCT PV / 

GOAL 

RATE 

(Yearly) 

TIME 

(Years) 

EMI / 

DEPOSIT 

ACTION REQUIRED 

2 C-

101 

Rahul Car Loan 8,00,000 10.50% 5 ? Calculate EMI (PMT) 

3 C-

102 

Sneha Home Loan 40,00,000 8.50% 20 ? Calculate EMI (PMT) 

4 C-

103 

Amit SIP Invest 0 12.00% 15 -5,000 Find Maturity (FV) 

5 C-

104 

Pooja Child Plan 0 7.50% 10 -10,000 Find Maturity (FV) 

6 C-

105 

Vikram Loan 

Check 

? 11.00% 5 -15,000 Find Max Loan (PV) 

7 C-

106 

Anjali Audit (Int) 5,00,000 10.00% 5 ? 1st Month Interest 

(IPMT) 

8 C-

107 

Anjali Audit (Prn) 5,00,000 10.00% 5 ? 1st Month Principal 

(PPMT) 

9 C-

108 

Rohit Repayment 2,00,000 14.00% ? -6,000 Find Duration (NPER) 

10 C-

109 

Karan Gold Loan 1,00,000 ? 2 -5,000 Find True Rate 

(RATE) 

11 C-

110 

TCS Project Ln 50,00,000 9.00% ? -1,00,000 Find Duration (NPER) 

 

Q.1. Find the Monthly EMI for Rahul's Car Loan. 

Q.2. Find the Monthly EMI for Sneha's Home Loan. 

Q.3. Find the Maturity Value of Amit's SIP Investment. 

Q.4. Find the Maturity Value of Pooja's Child Plan (RD). 

Q.5. Find the Maximum Loan Amount Vikram can get (Loan Eligibility). 

Q.6. Find the Interest Amount for the 1st Month of Anjali's Loan. 

Q.7. Find the Principal Amount for the 1st Month of Anjali's Loan. 

Q.8. Find the Total Duration (Months) to repay Rohit's Loan. 

Q.9. Find the Actual Interest Rate charged on Karan's Gold Loan. 

Q.10. Find the Duration (Months) to repay TCS Company's Project Loan. 
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Solution: 

1. Formula: =PMT(E2/12, F2*12, -D2) 

Result: 17,195.96 

2. Formula: =PMT(E3/12, F3*12, -D3) 

Result: 34,712.96 

3. Formula: =FV(E4/12, F4*12, G4) 

Result: 25,22,880.19 

4. Formula: =FV(E5/12, F5*12, G5) 

Result: 17,79,303.35 

5. Formula: =PV(E6/12, F6*12, G6) 

Result: 6,89,893.13 

6. Formula: =IPMT(E7/12, 1, F7*12, -D7) 

Result: 4,166.67 

7. Formula: =PPMT(E8/12, 1, F8*12, -D8) 

Result: 6,457.52 

8. Formula: =NPER(E9/12, G9, D9) 

Result: 40.4 Months 

9. Formula: =RATE(F10*12, G10, D10) * 12 

   (Note: Multiply by 12 to convert Monthly Rate to Yearly). 

Result: 18.16% 

10. Formula: =NPER(E11/12, G11, D11) 

Result: 60.8 Months 
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PROJECT – 2 

 A B C D 

1 PROFIT AND LOSS STATEMENT FOR ABC GROUP OF COMPANIES 

2 SALES   100000 

3 COST OF PURCHASE 35% OF SALES  ??? 

4 GROSS PROFIT   ??? 

5 EXPENSES    

6 ADVERTISEMENT 18% OF GP ???  

7 SALARIES  22000  

8 ELECTRICITY  2000  

9 TELEPHONE  5780  

10 MISC.  2100  

11 TOTAL EXPENSES  ???  

12 PROFIT   ??? 

13 INCOME TAX ON PROFIT 35% OF PROFIT  ??? 

14 NET PROFIT   ??? 

 

Questions: 

1) Calculate Costs of Purchases as 35% of Sales. 

2) Calculate Gross profit as Gross Profit=Sales - Cost of Purchase. 

3) Calculate Advertisement as 18% of Gross profit. 

4) Calculate Total Expenses as Advertisement + Salaries + Elec. + Tele phone + Misc. 

5) Calculate Profit as Profit = Gross Profit - Total Expenses. 

6) Calculate Income Tax as 35 % of Profit. 

7) Calculate Net Profit as Net Profit = Profit - Income Tax. 

Solutions:  

1) Cost of Purchase: -  =D2*35% 

2) Gross Profit: -  =D2-D3 

3) Advertisement: -  =D4*18% 

4) Total Expenses: -  =C6+C7+C8+C9+C10 

5) Profit: -   =D4-C11 

6) Income Tax on Profit: - =D12*35% 

7) Net Profit: -   =D12-D13 
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Project-3 

Create this table. Fill data up to Column F. Leave G to R blan. 
 

A B C D E F G H I J K L M N O P Q 

1 PAYROLL STATEMENT FOR IITM PVT. LTD. 

2 I

D 

NA

ME 

PO

ST 

FIX

ED 

SAL 

DA

YS 

OT 

HR

S 

LO

AN 

BAL 

LO

AN 

EMI 

BAS

IC 

HR

A 

OT 

AM

T 

BON

US 

GRO

SS 

P

F 

E 

S

I 

TO

T 

DE

D 

NE

T 

SA

L 

3 10

1 

Rajes

h 

Mgr 6000

0 

30 0 ? ? ? ? ? ? ? ? ? ? ? 

4 10

2 

Sneh

a 

HR 4500

0 

28 5 ? ? ? ? ? ? ? ? ? ? ? 

5 10

3 

Amit Dev 4000

0 

30 20 ? ? ? ? ? ? ? ? ? ? ? 

6 10

4 

Pooj

a 

Dev 4000

0 

15 0 ? ? ? ? ? ? ? ? ? ? ? 

7 10

5 

Vikr

am 

Acct 3500

0 

29 10 ? ? ? ? ? ? ? ? ? ? ? 

8 10

6 

Anjal

i 

Sale 2500

0 

30 15 ? ? ? ? ? ? ? ? ? ? ? 

9 10

7 

Roha

n 

Sale 2500

0 

0 0 ? ? ? ? ? ? ? ? ? ? ? 

9 10

8 

Kara

n 

Clrk 1800

0 

26 8 ? ? ? ? ? ? ? ? ? ? ? 

1

0 

10

9 

Sum

an 

Hel

p 

1200

0 

30 30 ? ? ? ? ? ? ? ? ? ? ? 

1

1 

11

0 

Rahu

l 

Grd 1500

0 

25 12 ? ? ? ? ? ? ? ? ? ? ? 

 

Question: 

1) The company has decided to give an automatic "Personal Loan" to  employees.If the Fixed Salary is greater 

than 40,000, the employee gets 70% of their salary as a Loan. Otherwise, the Loan Amount is 0. 

2) Some employees have taken a "Company Loan" for 10 years,The company charges 7% interest on this loan. 

calculate the Monthly EMI. 

3) The 'Fixed Salary' given in the table is for a full 30-day month. However, employees are paid only for the days 

they actually worked. calculate the 'Basic Pay' . To do this, find the salary for one day (divide Fixed Salary by 

30) and then multiply it by the 'Days Present'. 

4) Calculate HRA 40% of Basic Salary. 

5) Insert a DA column after HRA column, 
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6) Calculate DA 30% of Basic Salary. 

7) Calculate the 'OT Amount' . Assume a standard duty of 8 hours per day. First, determine the per-hour salary by 

dividing the Fixed Salary by 30 and then by 8. Finally, multiply this hourly rate by the total 'OT Hrs' worked 

by the employee. 

8) Calculate the 'Festival Bonus'. The company policy states that a bonus of ₹ 5,000 will be given ONLY to those 

employees who have been present for more than 25 Days. For others, the bonus is 0. 

9) Calculate Gross Salary as You need to add Basic Pay, HRA, DA, OT Amount, and Bonus together. 

10) Calculate the 'PF' (Provident Fund) deduction. According to the Company rules, 12% of the earned 'Basic 

Pay' must be deducted for PF. 

11) Calculate the 'ESI' (Medical Insurance) deduction. It should be calculated as 0.75% of the 'Gross Salary'. 

12) Calculate the 'Total Deduction'. This is the total amount to be cut from the salary. You need to add PF, ESI, 

and the 'Loan EMI'  together. 

13) Calculate the 'Net Salary'. This is the final amount the employee will take home. To find this, subtract 

the 'Total Deduction' from the 'Gross Salary' 

14) Set the sheet for print in one sheet, and highlight the heading, 

 

Solution: 

1. =IF(D2>40000, D3*70%, 0) 

2. =PMT(7%/12, 120, -G3) 

3. =(D3/30)*E2 

4. =I2*40% 

5. Mouse right click on OT Amt →Click on isert→column 

6. =I3*30% 

7. =(D3/30/8)*F3 

8. =IF(E3>25, 5000, 0) 

9. =SUM(I3:M3)    -- (Basic + HRA + DA + OT + Bonus) 

10. =I3*12% 

11. =N3*0.75% 

12. =O3+P3+H3 

13. =N3-Q3 
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PROJECT- 4 

 

  

 

 

 

 

 A B C D E 

1 
EMI NO. MONTHLY EMI 

INTERST ON 

EVERY EMI 

PRINCIPLE OF 

EVERY EMI 

BALANCE 

PAID 

2 0    100000 

3 1 16133.50 12500.00 3633.50 996366.50 

4 2 ??? ??? ??? ??? 

5 3 ??? ??? ??? ??? 

6 4 ??? ??? ??? ??? 

120 120 ??? ??? ??? ??? 

Question: 

1) Calculate the loan repayment for per month if the loan is to be paid in 10 years at an interest rate of 15% 

percent. 

2) Calculate Interest amount for the first installment from a given period. 

3) Calculate Principal amount of loan for the first installment from a given period. 

4) Calculated the total monthly payment of every installment and total dues as total loan – principle amount. 

5) Save it with Car Loan Report. 

Solution: 

1) Monthly Payment :- =pmt(15%/12,120,1000000) 

2) Interest Payment:- =ipmt(15%/12,A3,120,1000000) 

3) Principal Payment:- =ppmt(15%/12,A3,120,1000000) 

4) Total Dues:- =Total Loan – Principal Amount 

 

 

 

 

 

 

 

 

 

 

 

 

LOAN AMOUNT        1000000 

ANNUAL INTEREST RATE     15% 

NUMBER OF PAYMENT           120 

MONTHLY EMI               16133.50 
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LOOKUP & REFERENCE FUNCTIONS 

Emp ID Full Name Department Designation Joining Date 

Basic 

Salary 

Performance 

Rating (1-4) 

IITM-

101 

Rahul 

Sharma 
IT Support 

Sr. 

Executive 
12-Jan-20 45000 3 

IITM-

102 
Priya Verma HR Manager 23-Mar-19 65000 4 

IITM-

103 
Amit Kumar Sales Team Lead 05-Jul-21 52000 2 

IITM-

104 
Sneha Gupta Operations Analyst 11-Nov-22 38000 1 

IITM-

105 

Vikram 

Singh 
IT Support Developer 19-Aug-20 48000 3 

IITM-

106 
Anjali Das Finance Accountant 30-Jan-18 55000 4 

IITM-

107 

Rohan 

Mehta 
Sales Executive 14-Feb-23 32000 2 

IITM-

108 
Kavita Roy HR Recruiter 09-Sep-21 41000 3 

IITM-

109 
Arjun Nair Operations Manager 01-Dec-17 72000 4 

IITM-

110 
Meera Iyer Finance Sr. Analyst 22-May-20 60000 1 

VLOOKUP (Vertical Lookup): Searches for a value in the first column of a table and returns a value in the same 

row from a specified column number. 

Syntax: =VLOOKUP(lookup_value, table_array, col_index_num, [range_lookup]) 

Example =VLOOKUP("IITM-106", A2:G11, 6, 0) 

Result: 55000 

XLOOKUP (Modern Lookup): Searches a range or an array for a match and returns the corresponding item from a 

second range or array. It works in any direction. 

Syntax: =XLOOKUP(lookup_value, lookup_array, return_array) 

Example: =XLOOKUP("IITM-103", A2:A11, C2:C11) 

Result: Sales 

LOOKUP:Looks up a value in a one-column range and finds a value from the same position in a second one-column 

range. 

Syntax: =LOOKUP(lookup_value, lookup_vector, result_vector) 

Example: =LOOKUP("IITM-110", A2:A11, B2:B11) 

Result: Meera Iyer 

CHOOSE:Uses an index number to select a value from a list of options. 

Syntax: =CHOOSE(index_num, value1, value2, value3, value4) 

Example: =CHOOSE(G2, "Needs Improvement", "Average", "Good", "Excellent") 

Result: Good 
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INDEX:"Returns the value of a cell at the intersection of a particular row and column. 

Syntax: =INDEX(array, row_num, [column_num]) 

EXAMPLE:  =INDEX(A2:G11, 2, 4) 

Result: Manager 

MATCH:Returns the relative numeric position of an item in a range of cells. 

Syntax: =MATCH(lookup_value, lookup_array, [match_type]) 

EXAMPLE: =MATCH("Vikram Singh", B2:B11, 0) 

Result: 5 

HLOOKUP:Searches for a value in the top row of a table and returns a value in the same column from a specified 

row. 

Syntax: =HLOOKUP(lookup_value, table_array, row_index_num, [range_lookup]) 

Metrics 
Jan-24 

Feb-

24 Mar-24 Apr-24 

May-

24 Jun-24 

Total 

Sales 
50000 65000 48000 72000 85000 90000 

Cost 30000 35000 28000 40000 45000 50000 

Net Profit 20000 30000 20000 32000 40000 40000 

Bonus % 2% 4% 1% 5% 7% 8% 

EXAMPLE: =HLOOKUP("Feb-2024", A1:G5, 2, 0) 

Result: 65000 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 MS - EXCEL 
 

30                                                                                                                                                                                        WWW.ICAEDU.CO.IN 
 

HOME TAB (ALT + H) 

CLIPBOARD GROUP 

 

Cut (Ctrl + X): Removes the selected data from its original location so it can be moved to a new place. 

Copy (Ctrl + C): Creates a duplicate of the selected data without removing the original. 

Format Painter: A magic tool that copies only the formatting (Color, Font, Border) from one cell and applies it to 

another. 

How to use: Click a designed cell → Click Format Painter → Click the normal cell. 

Note: Before using any of below options, you must Select data and copy it (Ctrl + C) first. 

Paste (Ctrl + V): Inserts the data that was last Cut or Copied at the current cell location. 

 There are many types of paste options available in Excel. Which appear when you click on paste 

dropdown box: 

Paste (P): It pastes everything (Text, Formulas, Color, and Borders) exactly as it is. (Standard Paste). 

𝑓𝑥 Formulas (F): It pastes only the text and formulas, but removes all colors, bold styles, and borders. 

%𝑓𝑥 Formulas & Number Formatting (O): It paste the formula and keeps the specific number style (like 

Currency $, Percentage %, or Date format). 

    Keep Source Formatting (K): It pastes the content and ensures it looks exactly like the original cell (Same Color, 

Font, and Size). 

   No Borders (B): It pastes the data and colors but removes all borders (lines) around the cells. 

↔️ Keep Source Column Widths (W): It pastes the data and automatically adjusts the width of the new column to 

match the original one. 

    Transpose (T): It rotates the data. It converts Vertical (Rows) data into Horizontal (Columns) and horizontal to 

vertical. 

123 Values (V): It removes the formula and pastes only the Result/Answer. (Best for fixing data). 

%123 Values & Number Formatting (A): It pastes the Result (no formula) and keeps the number format (like Date 

or Rupee symbol). 

   123 Values & Source Formatting (E): It pastes the Result (no formula) and keeps all the colors and designs. 

    Formatting (R): It pastes only the Design (Color, Border, Font style) but does not paste the text or numbers. 

   Paste Link (N): It creates a live link to the original data  and duplicate data,  If you change the original data, this 

data will update automatically in duplicate data. 

           Picture (U): It converts your data into a Static Image (Photo). You cannot edit the text inside it. 

             Linked Picture (I): It pastes the data as a Live Screenshot. If you change the original data, the image updates 

automatically. 

Paste Special 

Add: Adds the value currently in the clipboard (copied value) to the values in the destination cells. 

Subtract: Subtracts the value in the clipboard from the values in the destination cells. 

Multiply: Multiplies the values in the destination cells by the value in the clipboard. 

Divide: Divides the values in the destination cells by the value in the clipboard. 
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Comments: Pastes only the Notes or Comments attached to the copied cell. It does not paste the text, numbers, or 

formatting of the cell. 

Validation: Pastes only the Data Validation rules (such as Dropdown lists, date limits, or input restrictions) from the 

copied cell, without changing the existing data in the destination cell. 

Skip Blanks: When pasting a range of data, this option ensures that empty (blank) cells in the copied range do not 

overwrite the existing data in the destination range. 

FONT GROUP 

Note: You have already learned most of these options in MS-Word. They work exactly the same way in Excel. 

Change Font Style & Size: Change the writing style (Font Face) and increase or decrease the text size. 

Highlight Text: Make text Bold (B), Italic (I), or <u>Underline (U)</u> to emphasize important data. 

Add Color: Change the Font Color (Text color) or apply a Fill Color (Background color) to the cell. 

Apply Borders (Grid): [Important for Excel]: Add lines around the cells to create a proper Table structure (e.g., All 

Borders, Thick Box Border). 

PARAGRAPH GROUP 

Horizontal Alignment 

Left Align, Centre Align, Right Align: You have already learned these in Word. They work the same as word. 

Decrease/Increase Indent: Moves text slightly away from the cell border. (Also same as Word). 

Vertical Alignment 

Top Align: Moves the text to the top edge (ceiling) of the cell. 

Middle Align: Centres the text vertically (between top and bottom). This looks most professional. 

Bottom Align (Default): Keeps the text at the bottom edge (floor) of the cell. 

Orientation: This tool rotates your text diagonally or vertically in cell. 

Wrap Text: Wrap Text" folds long text into multiple lines within the same cell. 

Merge & Centre: Combines two or more selected cells into One Big Cell and centres the text inside it. 

Merge Across: It combines columns but keeps each row separate. 

Merge Cells 

Merge cell: Combines selected cells into one single cell, but does NOT change the alignment of the text. (Text stays 

Left or Right, wherever it was). 

Unmerge Cells: Splits the currently merged cell back into individual small cells. 

Process: - 

➢ Select more than one cells. 

➢ Click on home tab. 

➢ Click on merge & center drop down. 

➢ Select option as you need. 

NUMBER GROUP 

Number Format Dropdown: The big box that currently says "General". Which help we can set what kind of data 

available in a cell. 

• Common Options available in dropdown: 
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• General: No specific format (Default). 

• Number: Displays numbers with decimals (e.g., 1500.00). 

• Currency/Accounting: Adds a currency symbol (e.g., ₹ 500 or $ 500). 

• Short Date/Long Date: Converts numbers into dates (e.g., 25-Oct-2023). 

• Text: Treats numbers as text (Useful for mobile numbers starting with 0). 

Accounting Number Format: It adds a Currency Symbol (like $ or ₹) and sets the decimal places to 2 fixed points. 

 Percent Style (%): It multiplies the cell value by 100 and adds a percentage sign (%).  

Comma Style (,): It adds a "Thousands Separator" to large numbers to make them readable. It basically applies 

accounting format without the currency symbol. 

Increase / Decrease Decimal: - Adds / remove more digits after the dot. 

Process: 

➢ Click on home tab. 

➢ Click on option from number group as you need. 

Custom Number Formatting: It is part of number group which help we can custom cell, how to value display value 

in cell. 

For this we have follow given steps: 

Process:  

Select cell / Range of cells. →Click on home tab →Click on number dialog box. / Press Ctrl + 1 →Format Cell 

box will be open. → Go to the Number tab → Custom →i n the Type box, enter the code from the examples 

below. 

The Attendance Tracker: - If you want Type 1→ see Present (Green). Type 0 → see Absent (Red). Type below code 

in custom box. 

Code: → [Green]"Present”; [Red]"Absent" 

Adding Units: Excel cannot calculate text. If you type "50 kg", Sum won't work. Use this instead. Or display unit 

with number as: 50PCS,10 KG, 2Quintal etc. Type below code in custom box. 

Code: → 0 "kg" 

Automatically add the country code as: 8271055515 → see +91-8271055515. 

Code: "+91-"0000000000 

Display positive numbers normally, but make negative numbers Red and in brackets. 

Code: [Green]0; [Red] (0) 

Leading Zeros (ID Cards): Usually, if you type 001, Excel changes it to 1. This forces the zeros to stay. As:  Type 1 

→ see 001. 

Code: 0000 

The "Invisible" Cell (Hide Data) as: Type Anything → see Nothing.  

Code: ;;; 

Large Numbers show K instead thousand. As Type 15000 → see 15K. 

Code: 0,"K" 

Auto-Prefix as Type 105 → see INV-105. , Type 102 → see IITM -102 

Code: "INV-"000 / "IITM-"000 



 

 MS - EXCEL 
 

33                                                                                                                                                                                        WWW.ICAEDU.CO.IN 
 

Code: \I\I\T\M\-000 

STYLE GROUP 

Conditional Formatting: Conditional Formatting  is a feature in Excel that automatically changes the color or style of 

a cell based on specific rules or conditions. 

Create record as: 

 A B C D E F 

1 Invoice ID Salesman Sales Amount Stock Qty Payment Status Column F (City) 

2 INV-1001 Rahul 50000 50 Paid Patna 

3 INV-1002 Amit 15000 5 Pending Chapra 

4 INV-1001 Ravi 85000 25 Paid 
 

5 INV-1003 Priya 9000 8 Pending Muzaffarpur 

6 INV-1004 John 62000 100 Cancelled Gaya 

 

Example: To check duplicate value 

Process: 

Select the column of data. →Go to Home Tab → Conditional Formatting. →Click Highlight Cell 

Rules → Duplicate Values. →Click OK. 

Example: To check pending value 

Process: 

Select the "Status" column. →Go to Home Tab → Conditional Formatting. →Click Highlight Cell Rules → Text 

that Contains. →Type "Pending" in the box. 

→Select Yellow Fill (or any color). →Click OK. 

Example: Highlight Low Stock 

Process:  

Select the "Quantity" or "Marks" column. →Go to Home Tab > Conditional Formatting. →Click Highlight 

Cell Rules → Less Than. →Type 10 (or 33). → Select Red Text or Red Fill. →Click OK. 

Example: Visualizing Sales Performance  

Process:  

Select the "Sales Amount" column. →Go to Home Tab > Conditional Formatting. 

Click Data Bars. →Select Blue Data Bar. 

Example: Highlight Empty Cells 

Process: 

Select your data range. → Go to Home Tab > Conditional Formatting → New Rule. 
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Select "Format only cells that contain". → In the drop-down list, change "Cell Value" to Blanks. → Click 

the Format button, choose color, and click OK. 

To remove rule 

Process: Home tab →Go to Conditional Formatting → Clear Rules → Clear Rules from Selected Cells. 

 

Format as Table: Format as Table converts your normal list of data into a "Smart Table".It does not just add colors 

and borders; it adds special powers to your data, like automatic filters, easy formulas, and auto-updating formats. 

Process: 

➢ Select your entire data. 

➢ Go to Home Tab. 

➢ Click on Format as Table. 

➢ Choose any design (Blue, Green, or Black). 

➢ A box will appear. Make sure "My table has headers" is checked (because your table has headings like Name, 

City). 

➢ Click OK. 

Cell Styles: Cell Styles are pre-designed formats for individual cells. Instead of manually changing Font Size, Color, 

and Border one by one, you can click one button to apply a professional look (like "Good", "Bad", "Heading", or 

"Total"). 

Process: 

➢ Click on any cell (For example, select the cell with "Pending"). 

➢ Go to Home Tab. 

➢ Click on Cell Styles. 

➢ Click on "Bad" (It will turn Red) or "Neutral" (It will turn Yellow). 

CELLS GROUP 

Insert: It allows you to add new cells, rows, columns, or worksheets into your current workbook. 

Types of Insert Options: 

• Insert Cells: Adds a single cell and asks where to shift the existing data. 

• Insert Sheet Rows: Adds a full horizontal line (row) above the selected cell. 

• Insert Sheet Columns: Adds a full vertical line (column) to the left of the selected cell. 

• Insert Sheet: Creates a brand-new Worksheet (Tab) in the file. 

Process: 

Click on Home Tab →Click on Insert →Select option as you need. 

Delete: It is used to permanently removes cells, rows, columns, or worksheets from the workbook. 

Types of Delete Options: 

• Delete Cells: Removes specific cells and shifts surrounding data to fill the gap. 

• Delete Sheet Rows: Removes the entire horizontal row selected. 

• Delete Sheet Columns: Removes the entire vertical column selected. 

• Delete Sheet: Permanently deletes the current worksheet and all its data. 

Process: 
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Click on Home Tab →Click on Delete →Click on an option according to need. 

Format: It changes the Row Height, Column Width, Visibility (Hide/Unhide), and Security (Protection). 

 There are many option available in format: 

• Row Height: Allows you to manually type a number to set the height of a row (e.g., 20 or 30). 

• AutoFit Row Height: Automatically adjusts the row height to fit the font size of your text. 

• Column Width: Allows you to manually type a number to set the width of a column. 

• AutoFit Column Width (Most Important): Automatically expands the column so that the longest text fits 

perfectly. 

• Default Width: Resets the column width to the standard Excel size (8.43). 

• Hide Rows: Makes the selected row disappear from view. 

• Hide Columns: Makes the selected column disappear. 

• Hide Sheet: Hides the entire Worksheet tab. 

• Unhide Rows/Columns: Brings the hidden data back. 

• Rename Sheet: Changes the name of the tab (e.g., changing "Sheet1" to "January Data"). 

• Move or Copy Sheet: Moves the current sheet to a different position or creates a duplicate copy of it. 

• Tab Color: Changes the background color of the sheet name (Good for organizing: Red for Urgent, Green for 

Done). 

Protect Sheet (Important): Locks the entire sheet with a password. No one can type, delete, or format unless they 

have the password. 

Lock Cell: This works with Protect Sheet. By default, all cells are "locked". If you uncheck this, people can 

edit only that specific cell even after protection. 

Format Cells: Opens the main detailed formatting box (Same as pressing Ctrl + 1). 

 

How to use "AutoFit Column Width" ? 

Process:  

(Use this when you see ###### or text gets cut off) 

Process: Click on the Column you want to fix (e.g., Column B). →Go to Home Tab →Click Format. 

→Click AutoFit Column Width. 

How to Hide a Column? 

(Use this when printing a report but you don't want to show sensitive columns) 

Process: Click on the Column header you want to hide (e.g., Column D). →Go to Format > Hide & Unhide. 

→Click Hide Columns. 

How to Rename a Sheet? 

Process: Click on the Sheet you are working on. →Go to Format. →Click Rename Sheet. 

The name at the bottom will be highlighted. → Type the new name (e.g., "Sales Data"). 

Press Enter. 

How to Protect your Sheet? 

Process: Go to Format. →Click Protect Sheet. →A box will open. Type a Password (e.g., 123). →Click OK. 

How to Copy Sheet? 
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Process: Go to Home Tab → Format. → Click on Move or Copy Sheet. →A small box will open. → Check the 

small box at the bottom that says "Create a copy" (Tick mark ☑). →In the list, choose where you want it 

(e.g., (move to end)). →Click OK. 

How to Lock Cell? 

Process:-  

1. Select the cell where you want  to type (e.g., Cell A1). 

2. Go to Home Tab → Format. 

3. Click on Lock Cell. 

(Note: The small box around the icon will disappear. This means Cell A1 is now "Unlocked"). 

4. Now, go to Format again. 

5. Click on Protect Sheet. 

6. Type a password (e.g., 123) and click OK. 

 

EDITING GROUP 

AutoSum (Σ): AutoSum is the fastest way to add numbers in Excel. 

 When you click the small arrow next to AutoSum, you get 5 common functions, 

1. Sum: Adds all the numbers (Total). 

2. Average: Finds the average value of the selected numbers. 

3. Count Numbers: Counts how many cells contain numeric values. 

4. Max: Finds the largest (highest) number in the list. 

5. Min: Finds the smallest (lowest) number in the list. 

6. More Functions is the gateway to Excel's huge library to show for use  over 450 formulas. 

Fill: The Fill command is used to copy data or formulas into adjacent cells (cells next to each other) quickly. instead 

of using Copy (Ctrl+C) and Paste (Ctrl+V), you can use Fill to repeat data or create number patterns. 

Options inside Fill 

• Down (Ctrl + D): Copies the value from the top cell to the cells below. 

• Right (Ctrl + R): Copies the value from the left cell to the cells on the right. 

• Up: Copies from the bottom cell to the top. 

• Left: Copies from the right cell to the left. 

Example:  

➢ Type Hello in Cell A1. 

➢ Select A1, A2, A3, and A4. 

➢ Click Fill > Down (or press Ctrl + D). 

➢ Result: All 4 cells will say "Hello". 

• Series: This is used to create a sequence of numbers (like 1, 2, 3, 4...) or Dates without typing them manually. 

Example:  

➢ Type 1 in Cell A1. 

➢ Select cells A1 to A10. 
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➢ Click Fill > Series. 

➢ A box will open. Make sure "Linear" is selected. 

➢ Click OK. 

➢ Result: Excel will fill numbers 1 to 10 automatically 

 Justify: This is a smart tool to fix long text. If you have a long sentence in one cell and want to break it into multiple 

rows below it, use Justify. 

Example: 

1. In Cell A1, type: "Excel is a very powerful software for data." 

2. Make Column A small (so the text doesn't fit). 

3. Select Cell A1 and the empty cells below it (A2, A3). 

4. Click Fill → Justify. 

5. Result: Excel will split the sentence 

Flash Fil (Ctrl + E): Flash Fill looks at what you typed in the first cell, learns the pattern, and does the same for the 

rest of the list. 

Example (Separating Names): 

• Column A (Full Name): 

• Rahul Kumar 

• Amit Singh 

• Priya Sharma 

Process: 

1. In Column B (First Name), type "Rahul" manually next to the first name. 

2. Click Fill →Flash Fill (or press Ctrl + E). 

3. Result: Excel will automatically fill Amit and Priya in the cells below. 

Clear:  It is used to clear the all, format, comments etc.  

Options inside Clear 

When you click the Clear button (Pink Eraser icon), you get 5 specific choices: 

 Clear All: Removes EVERYTHING. The data, the color, the borders, and the formulas. The cell becomes 

completely empty and new. 

Clear Formats: Removes only the Style (Colors, Bold, Borders, Date format). The Data (Text/Numbers) remains 

safe. 

 Clear Contents: Removes only the Data (Text/Numbers). The Style (Color/Border) remains there. 

Clear Comments/Notes: Removes any attached notes (the little red triangles in the corner) without deleting the data. 

Clear Hyperlinks: Removes the clickable link (blue color). 

Process:  

Select the cell →Click on home tab →Click on clear / Clear drop down →Select option as need 

Sort: Sort means to arrange your data in a specific order. A TO Z , Z TO A. 

Process: 

Select the Column you want to arrange →Go to Home Tab → Sort & Filter. →Click Sort A to Z. 
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Filter: It allows you to see only the data you need and hides the rest. 

Process Turn on Filter: 

Click on the top row (Headers) of your table. →Go to Home Tab → Sort & Filter button. →Click on Filter. 

(Result: Small arrows    will appear on the top of each column). 

Process to Use the Filter 

Click the small arrow    on the  column. →Uncheck the box that says (Select All). (This clears all checks). 

→Check the box which you want to filter. →Click OK 

Find: Used to locate a specific word or number in your sheet. 

Replace: Used to find a word and automatically change it to something else. 

Go To: Used to jump on specific cell. 

Go To Special: It allows you to select specific types of cells that are hard to select manually. 

Common Options inside Go To Special: 

• Formulas: Selects only the cells that contain formulas (Useful to check where formulas are used). 

• Comments: Selects all cells that have notes attached. 

• Blanks (Very Important): Selects only the empty cells. 

• Data Validation: Selects cells that have drop-down lists or rules. 

How to Fill All Blank Cells with "0"? 

Select your table. →Go to Find & Select > Go To Special. →Select Blanks. →Click OK. →(Result: Only 

empty cells are selected). → Type 0. →Press Ctrl + Enter. 
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INSERT TAB (ALT + N) 

TABELS GROUP 

Pivot Table: A Pivot Table is a data summarization tool in Excel. It takes a large, detailed table and instantly converts 

it into a small, summarized Report.It allows you to calculate totals, counts, or averages automatically by 

simply Dragging and Dropping headers. 

 A B C D E 

 Date Salesman City Product  Sales Amount 

1 01-Jan Rahul Patna Laptop 50000 

2 02-Jan Amit Delhi Mobile 15000 

3 03-Jan Priya Patna Mobile 20000 

4 04-Jan Rahul Delhi Laptop 45000 

5 05-Jan Amit Mumbai Laptop 60000 

6 06-Jan Priya Mumbai Mobile 12000 

7 07-Jan Rahul Patna Mobile 18000 

8 08-Jan Amit Delhi Laptop 55000 

 

Question: want to see the Total Sales done by each Salesman. 

Process to Create the Pivot 

Click anywhere inside your data table. →Go to the Insert Tab. →Click on PivotTable→A dialog box will be open 

→Define Table range →Check new worksheet. →Click OK. 

(A new sheet will open. On the right side, you will see a panel called "PivotTable Fields"). 

→Look at the Right-Side Panel. → lick on Salesman and drag it down to the ROWS box → Click on Sales 

Amount and drag it down to the VALUES box. → Excel will automatically create this summary for you 

Chart (Graph): A Chart is a Visual Representation of selected data. 

Process: Select Data →Click on insert Tab. →Select Chart type as you need. 

There are many Types of charts: 

Column Chart: It compares values between different categories side-by-side, and displays data using vertical 

bars (standing pillars). 

Sales Representative Total Revenue 

Raja 45,000 

John Smith 72,000 

Sarah Jones 58,000 

Michael Brown 70000 

 

 

Bar Chart: Displays data using horizontal bars. 

Product Model Name Units in Stock 

Samsung Galaxy S24 Ultra 5G 120 
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Apple iPhone 15 Pro Max 145 

Google Pixel 8 Pro (Obsidian) 85 

OnePlus 12 (Flowy Emerald) 110 

Xiaomi 14 Ultra Photography Kit 60 

 

Pie Chart: A Pie Chart is a circular graph that looks like a round Pizza or Pie. 

It is cut into "slices" of different sizes. The whole circle represents 100% (The Total). 

Expense Type Cost (Rs) 

House Rent 15000 

Food 8000 

Education 5000 

Savings 2000 

Doughnut Chart:A Doughnut Chart is exactly like a Pie Chart, but it has a hole in the center, It is preferred over Pie 

charts because it looks cleaner and professional. 

Line Chart:A Line Chart is a graph that connects data points with a continuous line (zig-zag).It is the best chart to 

show the Movement or Direction of data. It helps you see if something is going Up (Good) or Down (Bad) over a 

period of time. 

Month Profit (Rs) 

Jan 20000 

Feb 25000 

Mar 18000 

Apr 40000 

May 35000 

 

Stock Chart: Shows stock price fluctuations. Requires specific column order. 

High Low Close 

50 40 45 
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55 45 50 

60 50 55 

Combo Chart: It is a single graph that combines two different chart types, usually a Column Chart and a Line Chart. 

It is mainly used to compare two data sets with different units (e.g., Sales in Amount vs. Profit in Percentage) on the 

same screen using a Secondary Axis." 

How to Create and Format a Combo Chart in Excel? 

➢ Select Data & Click on  Insert tab. 

➢ Click on the Insert Combo Chart icon (looks like a Bar and Line mixed). 

➢ Select "Create Custom Combo Chart" at the bottom of the list. 

➢ A dialog box will open. Look at the bottom section. 

➢ For Total Sales: Select Clustered Column as the Chart Type. 

➢ For Profit %: Select Line as the Chart Type. 

➢ Secondary Axis: Check the box (  ) next to Profit %. 

➢ Click OK. 

➢ Click on the Chart Title and rename it to "Monthly Sales vs Profit Trend". 

➢ Click the Plus (+) button (Chart Elements) next to the chart. 

➢ Check the box for Axis Titles. 

➢ Rename the Left Axis to "Sales Amount". 

➢ Rename the Right Axis to "Profit %". 

➢ Click the Plus (+) button again. 

➢ Hover over Legend, click the small arrow (>) and select Bottom. 

➢ Right-click on any Blue Bar (Sales) -> Select Fill -> Choose a professional color (e.g., Dark Blue). 

➢ Click on the Orange Line (Profit) -> Go to Format tab -> Shape Outline -> Choose a contrasting color (e.g., 

Red). 

➢ Click on the horizontal Gridlines (background lines) and press Delete on your keyboard. 

➢ (Optional) Click the Plus (+) button and check Data Labels to show numbers on the line. 

 

 

When you click on (select) any Chart in Excel, 2 New Tabs automatically appear at the top of the Ribbon. These are 

collectively called "Chart Tools". 

1. Chart Design 

2. Format 

Chart Design Tab 

Purpose: Used to change the overall Look, Style, and Data of the chart. 

• Add Chart Element: To add Titles, Data Labels (Numbers), or Legends to your chart. 

• Quick Layout: To quickly change where the title and numbers appear. 

• Change Colors: To change the color theme (e.g., from Blue to Green). 

• Chart Styles: To apply ready-made professional designs (like a dark background or 3D look). 

Month 

Total 

Sales 

Profit 

% 

Jan 150000 10 

Feb 180000 12 

Mar 160000 8 

Apr 210000 15 

May 190000 14 

Jun 230000 18 

Jul 220000 16 

Aug 250000 20 

Sep 240000 19 

Oct 280000 22 

Nov 300000 25 

Dec 350000 28 
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• Switch Row/Column: To swap the X-axis and Y-axis data if the chart looks wrong. 

• Change Chart Type: To convert your chart from one type to another (e.g., changing a Column Chart to a Line 

Chart). 

Format Tab 

Purpose: Used to customize specific parts like Shapes, Borders, and Text. 

• Shape Fill: To color a specific bar or the background of the chart. 

• Shape Outline: To add a border around the chart or change the line thickness. 

• WordArt Styles: To make the text (Title or Labels) look fancy with shadows or glow. 

SPARKLINES GROUP 

Sparklines: Sparklines are "Mini Charts" that fit inside a Single Cell. 

Types of Sparklines 

There are 3 Types available in this group: 

1. Line: Shows a zig-zag line connecting data points. (Best for showing Trends over time). 

2. Column: Shows tiny vertical bars. (Best for Comparing values). 

3. Win/Loss: Shows simple blocks for Positive (Up) and Negative (Down) values. (Best for Profit vs Loss or 

Cricket Wins/Losses). 

Create table as below show: 

PRODUCT JAN FEB MAR APR RESULT 

PEN 10 15 12 20  

PENCIL 50 40 30 20  

ERASER 5 5 8 10  

Process: Go to Insert Tab. →Look for the Sparklines Group and click on Line. →A box will open asking for "Data 

Range". →Select the numbers for the first row (B2 to E2) i.e., 10, 15, 12, 20 with your mouse. →Click OK. 

FILTERS GROUP 

Slicer: A Slicer is a set of Visual Buttons used to filter data.Instead of clicking small arrows on column headers and 

selecting items from a list, you get a box with big buttons. You simply Click a Button  and the data filters instantly. 

Note: It works only on Official Excel Tables or Pivot Tables. 

Create table as shown below: 

SALESMAN CITY PRODUCT 

Amit Delhi Mobile 

Irshad Patna Laptop 

Suraj Chapra Tablet 

Khushi Mumbai Laptop 

Kashish Chapra Mobile 

Process: Select your entire data. → Press Ctrl + T on your keyboard and click OK. 

(This converts your normal data into an Official Excel Table). →Now, go to the Insert Tab. →Click on Slicer. →A 

box will open. Check the box for City. →Click OK. 
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(Result: A box with buttons "Delhi, Mumbai, Patna" will appear). →Try it: Click the Patna button. The table will 

instantly show only Patna rows. 

Timeline: A Timeline is a special slicer designed only for Dates. It lets you filter by Years, Quarters, Months, or Days 

using a slider bar. 

Note: It works ONLY on Pivot Tables. 

 

Create Table as shown below: 

DATE SALES 

01-Jan. 5000 

15-Feb. 8000 

20-Mar. 6000 

10-Apr. 9000 

17-May 3000 

Process: Select your data. → Go to Insert  → PivotTable and click OK. 

(Timeline does not work on normal Tables, it needs a Pivot Table). →In the Pivot Table, drag Date to Rows 

and Sales to Values. →Click anywhere inside the Pivot Table. →Go to the Insert Tab. →Click on Timeline. →Check 

the box for Date. →Click OK. (Result: A horizontal bar showing months will appear). → Click on "Jan" or drag the 

slider to select a range. 
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PAGELAYOUT TAB (ALT + P) 

PAGESETUP GROUP 

Print Area: Print Area allows you to select a specific part of your sheet to print, while ignoring the rest. 

Process: Select your data →Click on Pagelayout Tab →Click on Print area → Click on Print area. 

Clear print area:  It is used to clear the set print area. 

Process: Pagelayout tab → Print Area → Clear Print Area. 

Page break: It is used to set the page break from where you want the data in new page within a worksheet. 

Process: Select the cell from where you want to inset page break → Click on page layout tab→Click on Break → 

Click on insert page break. 

Background: It is used to add the image / logo in the background of a sheet. 

Process: Click on pagelayout tab →Click on background →Click on from a file →Select your image / logo →Click on 

open. 

Set Print Titles: The print titles function allows you to repeat the columns and rows heading at the beginning of each 

new page. 

Prcosess: Go to the Page Layout Tab. →Click on Print Titles. →A box will open. Click inside the white box 

next to "Rows to repeat at top". →Use your mouse to select Row 1 (or whichever row has your headers) 

directly from the sheet. → (It will look like $1:$1). →Click OK. 

SCALE TO FIT GROUP 

Width: Forces all Columns to fit on one single page width. 

Process: Go to the Page Layout Tab. →Look for the Scale to Fit group. →Click the dropdown arrow next 

to Width. →Select 1 Page. →Press Ctrl + P to check. 

Height:Forces all Rows to fit on one single page length. 

Process: Go to the Page Layout Tab. →Look for the Scale to Fit group. →Click the dropdown arrow next 

to Height. →Select 1 Page. →Press Ctrl + P to check. 

Scale:Manually changes the Size (%) of the printout. 

Process: Go to the Page Layout Tab. →Make sure both Width and Height are set to Automatic. →Go to 

the Scale box. →Type a lower number (like 80%) to make content smaller, or a higher number (like 110%) to 

make it bigger. →Press Enter. →Press Ctrl + P to check the result. 

Sheet Right-to-Left: Flips the sheet direction so Column A moves to the Right side (Used for Arabic/Urdu 

languages). 

Process: Go to Page Layout > Click Sheet Right-to-Left. 

Gridlines: It is used to view and print gridlines. 

Headings: It is used to view and print row & column header. 
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FORMULA TAB. (ALT + M) 

FUNCTION LIBRARY GROUP 

Insert Function (fx): The "Search Engine" for formulas. Use this if you don't know which formula to use. 

Process: Click on formula tab →Click on insert function → A box will open. In the "Search for a 

function" box, type a keyword (e.g., Loan). → Click Go. → Excel will suggest a list. Select PMT (which 

stands for Payment). → Click ok →Define argumets →click on ok. 

 

AutoSum: Quick access to basic math like Total, Average, and Count. 

Recently Used: Shows the history of formulas you used last. 

Financial: Formulas for Money, Loans, EMI, and Interest. 

Logical: Formulas for decisions (e.g., IF, AND, OR) to check True/False conditions. 

Text: Formulas to clean words (e.g., UPPER for Capital letters, TRIM to remove spaces). 

Date & Time: Formulas to insert Today’s date or calculate Age. 

Lookup & Reference: Formulas to search and find data in a list (e.g., VLOOKUP). 

Math & Trig: Formulas for pure math calculations (e.g., Rounding off numbers). 

 

DEFINED NAMES GROUP 

Define Name: Gives a specific name to a selected cell or range. 

Process: Select the data cells (e.g., Sales numbers from A1 to A10). →Go to Formulas Tab →Click Define 

Name. →In the "Name" box, type a nickname (e.g., TotalSales). →Click OK. 

Create from Selection: It work same as deine name but Automatically creates names using the Top Row or Left 

Column text as the name. 

Process: Select your whole table (Header + Data). →Click Create from Selection. →Check the box Top row (if 

your names are at the top). →Click OK. 

Use in Formula: Pastes the defined name into your formula so you don't have to type it. 

1. Process: Click on an empty cell for the total. →Type =SUM( →Click the button Use in Formula. →Select the 

name you created (e.g., TotalSales). →Press Enter. 

Name Manager: You can View, Edit, or Delete existing names. 

Process:  →Formula tab. →Click Name Manager. →You will see a list of all names. 

Select a name (e.g., TotalSales). →Click Edit (to change the area) or Delete (to remove it). 

FORMULA AUDITING GROUP 

Trace Precedents (Look Backward): Shows blue arrows coming from the cells that affect the selected formula. It 

answers: "Where did this number come from?" 

Process: Select a formula cell →Click on formulat tab → Click Trace Precedents. 

Trace Dependents (Look Forward): Shows blue arrows going to the cells that depend on the selected cell. It 

answers: "Where is this number being used?" 

Process: Select a number cell →Click on formulat tab→ Click Trace Dependents. 

Remove Arrows (Clean Up): Removes all the blue arrows drawn by the previous two buttons. 

Process:Click on formula tab → Click Remove Arrows. 
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Show Formulas (Shortcut: Ctrl + `):Switches the view to show the Formula  instead of the Result in every cell. 

Process:Click on formula tab → Click Show Formulas.  

Error Checking: Scans the sheet for common errors and suggests how to fix them (like a Spell Check for math). 

Process: Click on Formula tab →Click Error Checking. If an error is found, a dialog box will open with help. 

Evaluate Formula (Slow Motion): Calculates the complex formula Step-by-Step in slow motion. This is the best tool 

to find exactly which part of a long formula is wrong. 

Process:→Select the formula cell. →Click Evaluate Formula. →Keep clicking the Evaluate button to see the 

calculation steps one by one. 

Watch Window: Opens a small floating window that keeps an eye on important cells (like Grand Total) even when 

you scroll to a different sheet. It acts like a CCTV Camera. 

Process: Select the important cell (e.g., Total) →Click Watch Window →Click Add Watch. 

(Now, the value of that cell will always be visible in the floating box, no matter where you go). 

CALCULATION GROUP 

Calculation Options (The Engine Switch): Controls when Excel updates the formulas. It has 3 modes: 

Automatic (Default): Excel calculates the result immediately after you press Enter. 

Automatic Except for Data Tables: Calculates everything automatically, except for "Data Tables" (a specific 

What-If Analysis tool). 

Manual: Excel stops calculating automatically. If you change a number, the Total will NOT change until you 

force it to. (Used for very heavy/slow files). 

Process: Click on formula tab →Click on calulation option →Select option as you need. 

Calculate Now (Force Update)(F9): This button forces Excel to recalculate the Entire Workbook (All sheets).Use 

this ONLY when you are in "Manual Mode". Since Excel stopped calculating automatically, you click this button to 

tell Excel: "Okay, do the math now!”. 

Process: Make sure you are in Manual Mode. →Change some data. →Click on formula tab. →Click Calculate 

Now (or press F9). 

(Result: All formulas in the whole file will update). 

Calculate Sheet (Quick Update)( F9):This button forces Excel to recalculate Only the Current Active Sheet. 

Difference: "Calculate Now" updates the whole file (slow). "Calculate Sheet" updates only the page you are 

looking at (fast). 

Process: Go to the specific sheet you are working on. →Click Calculate Sheet. 

(Result: Only formulas on this page will update). 
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DATA TAB (ALT + A) 

GET & TRANSFORM DATA GROUP 

Get Data (Drop Down): It is used to insert data from  outside data source (like PDFs, Notepad, CSV, or Folders etc). 

Recent Sources (History): Shows a history list of files or websites you inserted / connected to recently, so you don't 

have to search for them again. 

Existing Connections (Link Manager): Shows a list of all active links in your workbook. Use this to delete or 

manage connections to other files. 

Process to get data from Text/CSV: 

➢ Go to Data Tab →Click From Text/CSV. 

➢ Select your file and click Import. 

➢ Click Load. (Messy text converts into a clean Excel Table). 

Process to get data from Web: 

➢ Copy the website link. 

➢ Go to Data Tab → Click From Web. 

➢ Paste the link and click OK. 

➢ Select the table you need and click Load. 

QUERIES & CONNECTIONS GROUPS 

Refresh All: It updates your Excel data by fetching the latest information directly from the connected external 

source (such as a Database, Website, or CSV file) and replacing the old values. 

Queries & Connections:The Queries & Connections button opens a side pane (window) on the right side of Excel 

that displays a complete list of all the external data sources linked to your workbook. 

Properties: It is the "Settings Button" where you tell Excel to update the data automatically so you don't have to click 

"Refresh" manually. 

Workbook links: It is a tool to fix, update, or remove the links when your formulas are pulling data from a different 

Excel file. 

These all above option will work after using get data. 

SORT & FILTER GROUP 

Sort: It us used to arrange date in Ascending(A – Z) and Descending (Z – A) order. 

Filter (Ctrl + Shift + L): The Filter tool allows you to view only the specific data you want to see by 

temporarily hiding the rows that do not meet your criteria. 

Clear (Clear Filter): This button removes the rules you applied but keeps the filter arrows. It effectively "unhides" all 

the data. 

Reapply: This is used when you change data after applying a filter. It tells Excel to verify the data and apply the filter 

rule again. 

Advanced Filter:It is a powerful tool in Excel that allows you to filter data using complex rules (criteria) written in 

separate cells. 

Process: 

➢ Create the conditon out of data range. 

➢ Select your data range. 
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➢ Click on Data Tab. 

➢ Click on Advanced. 

➢ Then a dialog box open. 

 

 

 

 

 

 

 

 

 

 

➢ Check copy to another location.  

➢ Click in list range box and select your all data. 

➢ Clilc on criteria range box and select your condition. 

➢ Click on copy to box and select empty cell. 

➢ Click on ok. 

DATA TOOLS GROUP 

Text to Columns: It is used to split the data from one cell into separate columns. 

Process: Select your cell → Click on data tab→ Click on text to columns→ Check delimited option → Click on next 

→ Check any option (Like: -Comma, Semicolon, Space etc) → Click on next → Click on finish. 

Flash Fill:Flash Fill is a smart tool that automatically fills data in a column when it detects a pattern.  

Process: 

➢ Suppose Column A has full names (e.g., Amit Kumar). 

➢ Go to the adjacent cell in Column B. 

➢ Manually type the First Name (Amit) exactly as you want it. 

➢ Press Enter. 

➢ Press the Shortcut Ctrl + E (or click the Flash Fill button). 

➢ Excel will automatically fill the rest of the names for all rows. 

Remove Duplicates:This tool scans a list or table to find repeated (duplicate) entries and permanently deletes them, 

leaving only unique records. 

Process: 

➢ Select your data range. 

➢ Go to the Data Tab -> Click Remove Duplicates. 

➢ A dialog box appears. 

• List Range: Select your main table.  

• Criteria Range: Select your rule box. 

• Copy to: Select an empty cell where you want the 

answer. 
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• If you want to check for duplicates based on all columns (entire row must be same), keep all boxes 

checked. 

• If you only want to check duplicates in one column (e.g., "Email"), select only that column. 

➢ Click OK. Excel will tell you how many duplicates were removed. 

Consolidate: Consolidate combines data from separate ranges (which can be on different sheets or even different 

workbooks) into one "Master Table." It can calculate the Sum, Average, Count, etc., of the combined data. 

Process: 

➢ Click on a blank cell where you want the result. 

➢ Go to Data Tab → Click Consolidate. 

➢ Function: Select Sum (or Average, Count, etc.). 

➢ Reference: Click the arrow icon, go to Sheet 1, and select the data range. Click Add. 

➢ Repeat this for Sheet 2 and Sheet 3 (Select range → Click Add). 

➢ Use labels in: Check Top row and Left column (if your data has headers and names). 

➢ Click OK. 

 

Data Validation:Data Validation restricts what a user can type into a specific cell. It ensures data accuracy by 

preventing invalid entries (like typing text in a date field). 

It has 3 main Tabs in its settings window: 

1. Settings: Define the rule (e.g., Whole number, List). 

2. Input Message: Shows a popup note when the cell is clicked. 

3. Error Alert: Shows a warning popup if the user types wrong data. 

Whole Number: It is a part of data validation setting menu, it Restricts the cell to accept only integers (complete 

numbers like 1, 10, 500). It will not accept decimals (like 1.5) or text. 

Process: 

➢ Select the range of cells. 

➢ Click Data Validation. 

➢ Allow: Select Whole number. 

➢ Data: Select between (or greater than, etc.). 

➢ Minimum: Type 1. 

➢ Maximum: Type 100. 

➢ Click OK. (User can only type numbers from 1 to 100). 

Decimal: Allows numbers with decimal points (like 10.5, 99.99). It is used when precision is needed. 

Process: 

➢ Select the cell. 

➢ Click Data Validation. 

➢ Allow: Select Decimal. 

➢ Data: Select greater than. 

➢ Minimum: Type 0. 

➢ Click OK. (User can type 50.50, but cannot type negative numbers). 
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List: Creates a Dropdown Menu in the cell. The user cannot type anything; they must pick an option from the list  

menu. 

Process: 

➢ Select the cell. 

➢ Click Data Validation. 

➢ Allow: Select List. 

➢ Type / select list. 

➢ Click on ok. 

Date: Restricts the cell to accept only valid Calendar Dates. 

Process: 

➢ Select the cell. 

➢ Click Data Validation. 

➢ Allow: Select Date. 

➢ Data: Select between. 

➢ Start Date: 01/01/2026. 

➢ End Date: 12/31/2026. 

➢ Click OK. (User can only enter dates within the year 2026). 

Text Length: Restricts the number of characters (letters/digits) a user can type. 

Process: 

➢ Select the cell. 

➢ Click Data Validation. 

➢ Allow: Select Text length. 

➢ Data: Select equal to. 

➢ Length: Type 10. 

➢ Click OK. (If the user types 9 or 11 digits, it will show an error). 

Custom (Advanced): Allows you to write a Formula to create complex rules that other options cannot handle. 

Process (Example: Allow Text Only): 

➢ Select the cell (e.g., A1). 

➢ Click Data Validation. 

➢ Allow: Select Custom. 

➢ Formula: Type =ISTEXT(A1). 

➢ Click OK. (Now, if a user types a number like "123", it will show an error. They must type text like "Amit"). 

Prevent Duplicate Entries 

➢ Select cells A1 to A10. 

➢ Go to Data Validation → Allow: Custom. 

➢ In the Formula box, type: =COUNTIF($A$1:$A$10, A1)=1 

➢ Click OK. 

➢ (Result: If you type "101" in cell A1, and try to type "101" again in cell A2, Excel will block it). 

Allow Uppercase Text Only 
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Process: 

➢ Select cell A1. 

➢ Go to Data Validation → Allow: Custom. 

➢ In the Formula box, type: =EXACT(A1, UPPER(A1)) 

➢ Click OK. 

(Result: If user types "apple", it shows error. If user types "APPLE", it is accepted). 

No Spaces Allowed: For Usernames, Passwords, or Email IDs where spaces are not allowed. 

Process: 

➢ Select cell A1. 

➢ Go to Data Validation -> Allow: Custom. 

➢ In the Formula box, type: =ISERROR(FIND(" ", A1)) 

➢ Click OK. 

(Result: "JohnDoe" is allowed. "John Doe" is blocked because of the space). 

Must Start with Specific Text (Prefix): Ensuring all Employee IDs start with "IITM" (e.g., IITM001). 

Process: 

➢ Select cell A1. 

➢ Go to Data Validation -> Allow: Custom. 

➢ In the Formula box, type: =LEFT(A1, 3)="IITM" 

➢ Click OK. 

(Result: "1001" will be blocked. "IITM1001" will be accepted). 

No Future Dates Allowed: Entering Date of Birth (DOB). A person cannot be born in the future. 

Process: 

➢ Select cell A1. 

➢ Go to Data Validation → Allow: Custom. 

➢ In the Formula box, type: =A1 <= TODAY() 

➢ Click OK. 

(Result: If today is Jan 1st, 2024, and the user enters Jan 2nd, 2024, Excel will show an error). 

 

FORECAST GROUP 

What-If Analysis:What-If Analysis is a set of tools in Excel that allows you to change the values in cells to see how 

those changes will affect the outcome of formulas. 

There are 3 main options (tools): 

Scenario: It is an analysis of MS-Excel which used to modify the value of de pending cell with desired output in 

multiple precedent cells. 

Process:  

➢ Select your data range which you have to modify 

➢ Click on data tab 

➢ Click on what if analysis 

➢ Click on scenario 
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➢ Click on add button 

➢ Enter any name 

➢ Click on ok  

➢ Modify the value of selected cells → Click on ok → Click on show. 

Goal Seek:It is an analysis of MS-Excel which used to modify the value of prece dent cell with desired output in the 

selected cell. 

Process: 

➢ Select your dependent cell value  

➢ Click on data tab 

➢ Click on what if analysis 

➢ Click on goal seek 

➢ Then a dialog box open  

➢ Select the formulated cell range which you want to modify in Set cell 

➢ Enter the new target value in To value  

➢ Select the cell range in which you have to share the value 

➢ Click on ok  

➢ Again click on ok 

Data Tables: Data Table is a tool that allows you to calculate multiple results for a single formula at the same time by 

testing a list of different input values. 

 

Create table as shown below: 

 A B C D 

1 Loan amount 500000   

2 Rate 10% 8% =B4 (Type here) 

3 Months 60 9%  

4 Emi =PMT(B2/12,B3,-B1) 11%  

5   12%  

 

Process: 

➢ Select your data (e.g. C2:D6) 

➢ Click on data tab. 

➢ Click on what if analysis 

➢ Click on data table. 

➢ Leave blank Row input cell because your table is verticaly, 

➢ Click n Column input cell and click on B2(interest rate) 

➢ Click on ok. 

(The empty cells in Column D (D3 to D6) will instantly fill with the EMI amounts.) 

Forecast Sheet:Forecast Sheet is a tool in Excel that uses historical data (past records) to predict future trends. It 

analyzes patterns in your data (like seasonal spikes or steady growth) and creates a visual chart and table estimating 

future values. 
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Your data must have a Date/Time column (Timeline) and a Value column (e.g., Sales). 

 A B 

1 Date Sales 

2 1-Jan-2024 1000 

3 1-Feb-2024 1200 

4 1-Mar-2024 1500 

5 1-Apr-2024 1400 

6 1-May-2024 1800 

7 1-June-2024 2000 

Process: 

➢ Select Data (e.g. A1:B7) 

➢ Click on data tab. 

➢ Click on forecast sheet. 

➢ A popup window will appear showing a Line Chart. 

Blue Line: Shows your past sales (Jan to Jun). 

Orange Line: Shows the predicted future sales. 

Forecast End: By default, Excel picks a date. You can change this date to determine how far into the future 

you want to predict (e.g., set it to 01-Sep-2024). 

➢ Click the Create button. 

Excel will automatically create a New Worksheet containing: 

• A Table: It will list the predicted sales for July, August, and September. 

• Confidence Interval: It adds two columns showing the "Lower Confidence Bound" (Minimum expected 

sales) and "Upper Confidence Bound" (Maximum expected sales). 

• A Chart: A visual graph showing the trend moving from the past into the future. 

 

OUTLINE GROUP 

Group: It allows you to bundle multiple rows or columns together so you can expand (show) or collapse (hide) them 

with a single click. It adds Plus (+) and Minus (-) buttons to the margin of your worksheet, helping you summarize 

detailed data. 

Process: Select multiple Rows / Columns. →Click on data tab, →Click on group. 

Auto Outline: It is an automated feature that creates groups based on the formulas in your data. It works exactly like 

manual grouping (adding + and - buttons) but saves time by detecting the Totals and Details automatically. If your 

data has proper Sum/Subtotal formulas, Auto Outline will group the detailed rows under the total rows 

instantly.(formulated data mandaory) 

Process: Select your data → Click on data tab. →Click on group drop down. →click on auto outline. 

Ungroup is used to remove the grouping from selected rows or columns. 

Clear Outline instantly removes ALL groups and levels from the entire selected dataset at once, deleting 

every + and - button completely. 
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Subtotal: It is a tool that automatically adds a "Total" row underneath every group in your list. It helps you quickly 

see the sum (or average/count) for each category without adding formulas manually. You must Sort your list (A to Z) 

before clicking Subtotal so that identical items are grouped together. 

Create data as shown below:  

Emp No. Name Post Location Salary 

IITM001 Raja Manager Delhi 85000 

IITM002 Irshad Developer Mumbai 65000 

IITM003 Prabhat Analyst Bangalore 55000 

IITM004 Amit Sharma HR Delhi 45000 

IITM005 Suman Verma Accountant Pune 40000 

IITM006 Rahul Singh Team Lead Mumbai 75000 

IITM007 Priya Kapoor Developer Bangalore 62000 

IITM008 Ankit Tiwari Admin Noida 35000 

IITM009 Vikas Mishra Designer Gurugram 48000 

IITM010 Sneha Gupta Manager Pune 82000 

IITM011 Rohan Das Analyst Hyderabad 53000 

IITM012 Pooja Reddy HR Chennai 46000 

IITM013 Manish Malhotra Developer Noida 60000 

IITM014 Suresh Patel Sales Head Ahmedabad 70000 

IITM015 Nisha Yadav Support Delhi 30000 

IITM016 Kiran Rao Team Lead Hyderabad 74000 

IITM017 Deepak Chopra Accountant Mumbai 42000 

IITM018 Arjun Mehra Designer Bangalore 50000 

IITM019 Simran Kaur Developer Chandigarh 61000 

IITM020 Farhan Khan Admin Kolkata 36000 

 

Process: 

➢ Sort the data The field you want to summarize by.(e.g. Post) 

Emp No. Name Post Location Salary 

IITM005 Suman Verma Accountant Pune 40000 

IITM017 Deepak Chopra Accountant Mumbai 42000 

IITM008 Ankit Tiwari Admin Noida 35000 

IITM020 Farhan Khan Admin Kolkata 36000 

IITM003 Prabhat Analyst Bangalore 55000 

IITM011 Rohan Das Analyst Hyderabad 53000 

IITM009 Vikas Mishra Designer Gurugram 48000 

IITM018 Arjun Mehra Designer Bangalore 50000 

IITM002 Irshad Developer Mumbai 65000 

IITM007 Priya Kapoor Developer Bangalore 62000 

IITM013 Manish Malhotra Developer Noida 60000 

IITM019 Simran Kaur Developer Chandigarh 61000 
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IITM004 Amit Sharma HR Delhi 45000 

IITM012 Pooja Reddy HR Chennai 46000 

IITM001 Raja Manager Delhi 85000 

IITM010 Sneha Gupta Manager Pune 82000 

IITM014 Suresh Patel Sales Head Ahmedabad 70000 

IITM015 Nisha Yadav Support Delhi 30000 

IITM006 Rahul Singh Team Lead Mumbai 75000 

IITM016 Kiran Rao Team Lead Hyderabad 74000 

➢ Click on data tab. 

➢ Click on subtotal. 

➢ A dialog box will be open.  As → 

➢ Selece post in “At each change in box.” 

➢ Select function  in “use fuction box” as “Sum” 

➢ Check Salary. 

➢ Click on ok. 

 

 

 

 

 

 

 

Result will be:  

Emp No. Name Post Location Salary 

IITM005 Suman Verma Accountant Pune 40000 

IITM017 Deepak Chopra Accountant Mumbai 42000 

    Accountant 

Total 

  82000 

IITM008 Ankit Tiwari Admin Noida 35000 

IITM020 Farhan Khan Admin Kolkata 36000 

    Admin Total   71000 

IITM003 Prabhat Analyst Bangalore 55000 

IITM011 Rohan Das Analyst Hyderabad 53000 

    Analyst Total   108000 

IITM009 Vikas Mishra Designer Gurugram 48000 

IITM018 Arjun Mehra Designer Bangalore 50000 

    Designer Total   98000 

IITM002 Irshad Developer Mumbai 65000 

IITM007 Priya Kapoor Developer Bangalore 62000 

IITM013 Manish Malhotra Developer Noida 60000 

IITM019 Simran Kaur Developer Chandigarh 61000 
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    Developer 

Total 

  248000 

IITM004 Amit Sharma HR Delhi 45000 

IITM012 Pooja Reddy HR Chennai 46000 

    HR Total   91000 

IITM001 Raja Manager Delhi 85000 

IITM010 Sneha Gupta Manager Pune 82000 

    Manager Total   167000 

IITM014 Suresh Patel Sales Head Ahmedabad 70000 

    Sales Head 

Total 

  70000 

IITM015 Nisha Yadav Support Delhi 30000 

    Support Total   30000 

IITM006 Rahul Singh Team Lead Mumbai 75000 

IITM016 Kiran Rao Team Lead Hyderabad 74000   
Team Lead 

Total 

 
149000 

  
Grand Total 

 
1114000 
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REVIEW TAB (ALT + R) 

PROOFING GROUP 

Workbook Statistics): It Counts Sheets, Cells, Formulas, Tables. 

 

COMMENT GROUP 

New Comment: Adds a new note/comment to the selected cell. 

Delete: Removes the comment from the selected cell. 

Previous: Jumps to the comment before the current one. 

Next: Jumps to the comment after the current one. 

Show/Hide Comment: Toggles visibility (Shows or hides the comment box for the selected cell). 

Show All Comments: Shows ALL comment boxes in the entire sheet at once. 

Process to insert comment: 

➢ Select cell  

➢ Click on Review tab. 

➢ Click on new comment. 

A yellow box will appear. Type your message inside it. 

➢ Click outside the box, 

➢ red triangle will appear in the top-right corner of the cell indicating a comment exists. 

➢ Move mouse pointer on it to show comment. 

Process to add image in comment box: 

Select commented cell. →Click on review tab. →Click on show/hide comment. → Comment box will appear. 

→Mouse right click on comment box border. →Click on format comment. →Format comment box will be 

appear. →Click on colors and lines tab. →Click on fill color drop down. →Click on fill effect. →Fill effect 

box will be appear →Click on picture tab. →Click on select picture. →Select your picture. →Click on insert.  

→Click on ok →Again click on ok 

PROTECT GROUP 

Protect Sheet: It secures the data inside the current / active worksheet with a password. It prevents unauthorized users 

from modifying (typing, deleting, or formatting) the content of the cells, ensuring the integrity of your data. 

Process: Open the worksheet you want to lock. → Review Tab → Click Protect Sheet. →Enter a Password 

→Check /Uncheck the actions you want to forbid (by default, users can only select cells). →Click OK → Confirm 

Password → Click OK. 

Protect Workbook: It secures the structure of the entire Excel file. It prevents users from adding, deleting, renaming, 

moving, or hiding/unhiding worksheets, ensuring the layout of the file remains unchanged. 

Process: Go to the Review Tab → Click Protect Workbook. →Make sure the Structure box is checked. →Enter 

a Password. →Click OK→ Confirm Password → Click OK 

Allow Edit Ranges:It is an advanced protection feature. It allows you to protect the entire worksheet while 

keeping specific areas (ranges) unlocked and editable for users. You can even set different passwords for different 

ranges. 

Process: Select your range of cells for edit →Click on review tab. →Click on allow edit ranges. →Click New.  
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Title: Name the range (e.g., "InputZone"). 

Refers to cells: Select the cells you want to keep editable (e.g., C1:C10). 

Range Password: Leave blank (for public access) or enter a password (for specific access). 

Click OK. →Click the Protect Sheet button at the bottom of the dialog box. →Enter a password to lock the rest 

of the sheet -> Click OK. 

Result: Users can only type in C1:C10; the rest of the sheet is read-only. 

Shareworkbook: Share Workbook is an Excel feature that allows multiple users connected to the same Local 

Network (LAN/Wi-Fi) to open, edit, and save changes to a single Excel file simultaneously. It tracks changes from 

everyone and merges them automatically. 

Process: 

➢ Connect your pc to internet. 

➢ Create folder On the Desktop or in the D: Drive, create a new folder. (e.g “SharedExcel”.) 

➢ Right-click on the SharedExcel folder. 

➢ Select Properties from the context menu. 

➢ In the Properties window, click the Sharing tab at the top. 

➢ Click the Share... button. 

➢ In the sharing window, open the dropdown list and select Everyone. 

➢ Click the Add button. 

➢ In the list below, you’ll see Everyone with Read permissions by default. 

➢ Change it to Read/Write so that other users can also modify files in the folder. 

➢ Click the Share button to confirm. 

➢ When the process completes, click Done. 

➢ Press Windows + R on your keyboard. 

➢ Type cmd and press Enter to open the Command Prompt. 

➢ In the black window, type ipconfig and press Enter. 

➢ Look for the IPv4 Address (for example: 192.168.1.5 or 192.168.0.10) and note it down. 

➢ Open Excel on the Main PC 

➢ Prepare the Data Create your data sheet (add headers, columns, and initial data as required). 

➢ Save the File inside the “SharedExcel" folder with a specific name (e.g., SalesData.xlsx). 

➢ Click on the Review tab  

➢ Click the Share Workbook button. 

(Note: If you cannot find this button, it may need to be added manually via the "Quick Access Toolbar" 

options, though it is usually visible by default in older versions of Excel). 

➢ A pop-up window will appear. Go to the Editing tab and check (tick) the box that says: 

"use the old shared workbook feature instead of the new co-authoring experience..." 

➢ Click on advanced tab and change setting as "Automatically every 5 minutes". 

➢ Click the OK button to apply the changes. 

➢ Excel will prompt a message asking to save the file again to update the sharing settings. Click OK or Yes. 

➢ Check the Title Bar at the very top of the Excel window. You should now see the word [Shared] written next to 

the file name, confirming the process is complete. 

➢ Move to the other computers that are connected to the same "Wifi" network as the Main PC. 

➢ On the client PC, press the Windows Key + R on your keyboard to open the Run dialog box. 

➢ Type the IP address of the Main PC (which you noted in Part 1). You must type two backslashes (\\) before the 

number. 

• Example: \\192.168.1.5 
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➢ Click OK or press Enter. 

➢ A window will open displaying the shared network resources. Locate the folder named "SharedExcel" and 

double-click to open it. 

➢ Inside the folder, you will see the SalesData.xlsx file. Open this file to begin working. 

 

Unshare Workbook: It Removes Multi-User Access Only one person can edit the file at a time after this. 

 

Hide ink: A feature that temporarily makes all drawings and highlighter marks invisible so you can view the 

underlying data clearly. It does not delete the ink. 

Process: 

➢ Go to the Draw Tab. 

➢ Use a Pen to scribble or draw something on the sheet. 

➢ Go to the Review Tab (Hide Ink is usually located here, even if you draw in the Draw Tab). 

➢ Click Hide Ink. (The drawing disappears). 

➢ Click Hide Ink again. (The drawing reappears). 

 

Delete All Ink on Sheet: A command that permanently removes every handwritten note, drawing, and ink stroke from 

the current worksheet. 

 

Delete All Ink on Workbook: A powerful command that permanently removes every single piece of ink, drawing, 

and handwritten note from the entire Excel file (all sheets/tabs) at once. 
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VIEW TAB (ALT + W) 

WORKBOOK VIEW GROUP 

Normal View: The default view used for standard data entry, formatting, and calculation without print constraints. 

Page Break Preview: A view designed to manage page boundaries, allowing users to adjust where pages split before 

printing. 

Page Layout View: A "Print-Ready" view that displays the worksheet exactly as it will appear on paper, useful for 

designing the layout. 

Custom Views: A feature that saves specific display settings (hidden rows, columns, or filters) to switch between 

different data perspectives instantly. 

Process to apply custom view: 

 Select range of cells→Click on view tab→ Click on custom view→ Click on add button→ Enter any name→ 

Click on ok. 

Process to view custom view: 

Put cursor anywhere in sheet →Click on view tab →Click on custom view. →Select your name→Click on show. 

Advance use of custom view: 

Process: 

Open your file →Apply custom view with a name as above process→Now hide the rows Select the rows you want 

to hide (e.g., Row 5 to Row 10). →Right-click on the selected row numbers. →Select Hide. →(Now those rows 

are gone from the screen). →Again, apply custom view with a new name. →after apply cutom view → View 

Tab →Custom Views. →Select "first name" → Click Show. → (All hidden rows will reappear instantly). →Go 

to View Tab → Custom Views again. →Select "Hidden Data View" → Click Show. → 

(Row 5 to 10 will disappear instantly). 

 

SHOW GROUP 

Gridlines: It is used to show / hide the gridlines. 

Formula bar: It is used to show / hide the formula bar. 

Heading: It is used to show / hide the row & column heading. 

ZOOM GROUP 

Zoom: It is used to choose a specific magnification percentage (e.g., 200%, 75%) to make the sheet look larger or 

smaller. 

100%: It is used to returns the sheet to its standard, default size. 

Zoom to Selection: It is used to Instantly magnifies only the specific cells you have highlighted so they fill the entire 

screen for better visibility. 

WINDOW GROUP 

Freeze Panes: It allows you to lock specific rows or columns so that they remain visible while you scroll through the 

rest of the worksheet. 

There are 3 Options: 

Freeze Top Row: Instantly locks only the very first row (Row 1) of the sheet. 

Freeze First Column: Instantly locks only the very first column (Column A) of the sheet. 
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Freeze Panes (Custom Freeze): Locks rows and columns based on your current selection. It freezes 

everything above and to the left of the selected cell. 

Process: 

To Freeze Top Row Only: 

Go to View Tab→ Freeze Panes → Freeze Top Row. 

To Freeze First Column Only: 

Go to View Tab → Freeze Panes → Freeze First Column. 

To Freeze Both (Row & Column) / Custom Area: 

Click the cell below the row and to the right of the column you want to freeze (e.g., Click B2 to freeze Row 1 

& Col A). → Go to View Tab → Freeze Panes→> Freeze Panes. 

To Remove Freeze: 

 Go to View Tab→ Freeze Panes → Unfreeze Panes. 

Split: Divides the Excel window into separate, independently scrollable panes. 

Hide: It is used to make the entire Excel workbook invisible without closing the file.  

How to Hide (Make Invisible): 

Process: 

➢ Go to the View Tab. 

➢ Click the Hide button in the Window group. 

 How to Unhide (Bring it Back): 

Process 

➢ Go to the View Tab again. 

➢ Click the Unhide button. 

➢ A small box will pop up listing the hidden files. 

➢ Select your file name and click OK. 

View side by side: Automatically arranges two open Excel files on the screen together for easy 

comparison.When Enables Synchronous Scrolling, meaning when you scroll one file, the other file scrolls with it 

automatically. 

Best For Checking line-by-line differences between two versions of a list (e.g., "Old List" vs. "New List"). 

Process: 

➢ Open two files. 

➢ Click View → View Side by Side. 

➢ Both files appear on screen; scrolling one moves both. 

Synchronous Scrolling: It locks the two files together so they scroll at the same time.It work when you apply view 

side by side. 

Reset Window Position: It fixes the position of the two windows on your screen. It works when you apply view side 

by side. 

Switch window: It displays a list of all currently open Excel workbooks. It allows you to quickly switch focus from 

one file to another by selecting its name from the list. 

Process: Open multiple excel file →Click on ViewTab →Click on Switch window. →Select your file. 
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 Save workspace: It is used to save multiple files within a file. This option available excel 2007 & 2010 version not 

available in new versions. 

Process: Open more than one file →Click on view tab →Arrange all →Again Click on view tab. →Click on save 

workspace →Enter your file name →Click on save. 

 

 

 


